libcli 0.0.5

  • Readme
  • Changelog
  • Installing
  • new50

libcli #

library for flutter projects

Github #

clone source code to local.

git clone

Project #

using project libcli.code-workspace

Test #

unit test

flutter test

debug test using vscode flutter extension

Contributing packages #

test to see if libcli is ready to publish

flutter packages pub publish --dry-run

publish libcli to

flutter packages pub publish

Changelog #

All notable changes to this project will be documented in this file.

[0.0.1] - 2019-10-01

initial open source release.

[0.0.2] - 2019-10-02

command service

[0.0.3] - 2019-10-05

merge proto_map into command service

[0.0.4] - 2019-10-06

add settings to store runtime service mode

[0.0.5] - 2019-10-08

remove IDCount from CommandService

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  libcli: ^0.0.5

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:libcli/command/command_service.dart';
import 'package:libcli/command/dio_mock.dart';
import 'package:libcli/command/proto_object.dart';
import 'package:libcli/settings.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Oct 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/settings.dart. (-0.50 points)

Analysis of lib/settings.dart reported 1 hint:

line 3 col 8: Unused import: 'package:flutter/foundation.dart'.

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field was unreachable.

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (protobuf).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and libcli.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
dio ^3.0.1 3.0.3
flutter 0.0.0
protobuf ^0.14.3 0.14.4 1.0.0
rxdart ^0.22.2 0.22.4
Transitive dependencies
charcode 1.1.2
collection 1.14.11 1.14.12
fixnum 0.10.9
http_parser 3.1.3
meta 1.1.7
path 1.6.4
sky_engine 0.0.99
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies