libcli 0.0.16

  • Readme
  • Changelog
  • Installing
  • 41

libcli #

library for flutter projects

Github #

clone source code to local.

git clone git@github.com:piyuo/fl-libcli.git

Project #

using project libcli.code-workspace

Test #

unit test

flutter test

debug test using vscode flutter extension

Contributing packages #

test to see if libcli is ready to publish

flutter packages pub publish --dry-run

publish libcli to pub.dev

flutter packages pub publish  --force

Changelog #

All notable changes to this project will be documented in this file.

[0.0.1] - 2019-10-01 #

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  libcli: ^0.0.16

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:libcli/analytic/analytic.dart';
import 'package:libcli/command/command.dart';
import 'package:libcli/command/command_http.dart';
import 'package:libcli/command/command_protobuf.dart';
import 'package:libcli/command/command_url.dart';
import 'package:libcli/command/commands/google/any.pb.dart';
import 'package:libcli/command/commands/google/any.pbenum.dart';
import 'package:libcli/command/commands/google/any.pbjson.dart';
import 'package:libcli/command/commands/google/any.pbserver.dart';
import 'package:libcli/command/commands/google/api.pb.dart';
import 'package:libcli/command/commands/google/api.pbenum.dart';
import 'package:libcli/command/commands/google/api.pbjson.dart';
import 'package:libcli/command/commands/google/api.pbserver.dart';
import 'package:libcli/command/commands/google/descriptor.pb.dart';
import 'package:libcli/command/commands/google/descriptor.pbenum.dart';
import 'package:libcli/command/commands/google/descriptor.pbjson.dart';
import 'package:libcli/command/commands/google/descriptor.pbserver.dart';
import 'package:libcli/command/commands/google/duration.pb.dart';
import 'package:libcli/command/commands/google/duration.pbenum.dart';
import 'package:libcli/command/commands/google/duration.pbjson.dart';
import 'package:libcli/command/commands/google/duration.pbserver.dart';
import 'package:libcli/command/commands/google/empty.pb.dart';
import 'package:libcli/command/commands/google/empty.pbenum.dart';
import 'package:libcli/command/commands/google/empty.pbjson.dart';
import 'package:libcli/command/commands/google/empty.pbserver.dart';
import 'package:libcli/command/commands/google/field_mask.pb.dart';
import 'package:libcli/command/commands/google/field_mask.pbenum.dart';
import 'package:libcli/command/commands/google/field_mask.pbjson.dart';
import 'package:libcli/command/commands/google/field_mask.pbserver.dart';
import 'package:libcli/command/commands/google/googleProto_service.pb.dart';
import 'package:libcli/command/commands/google/source_context.pb.dart';
import 'package:libcli/command/commands/google/source_context.pbenum.dart';
import 'package:libcli/command/commands/google/source_context.pbjson.dart';
import 'package:libcli/command/commands/google/source_context.pbserver.dart';
import 'package:libcli/command/commands/google/struct.pb.dart';
import 'package:libcli/command/commands/google/struct.pbenum.dart';
import 'package:libcli/command/commands/google/struct.pbjson.dart';
import 'package:libcli/command/commands/google/struct.pbserver.dart';
import 'package:libcli/command/commands/google/timestamp.pb.dart';
import 'package:libcli/command/commands/google/timestamp.pbenum.dart';
import 'package:libcli/command/commands/google/timestamp.pbjson.dart';
import 'package:libcli/command/commands/google/timestamp.pbserver.dart';
import 'package:libcli/command/commands/google/type.pb.dart';
import 'package:libcli/command/commands/google/type.pbenum.dart';
import 'package:libcli/command/commands/google/type.pbjson.dart';
import 'package:libcli/command/commands/google/type.pbserver.dart';
import 'package:libcli/command/commands/google/wrappers.pb.dart';
import 'package:libcli/command/commands/google/wrappers.pbenum.dart';
import 'package:libcli/command/commands/google/wrappers.pbjson.dart';
import 'package:libcli/command/commands/google/wrappers.pbserver.dart';
import 'package:libcli/command/commands/shared/err.pb.dart';
import 'package:libcli/command/commands/shared/err.pbenum.dart';
import 'package:libcli/command/commands/shared/err.pbjson.dart';
import 'package:libcli/command/commands/shared/err.pbserver.dart';
import 'package:libcli/command/commands/shared/num.pb.dart';
import 'package:libcli/command/commands/shared/num.pbenum.dart';
import 'package:libcli/command/commands/shared/num.pbjson.dart';
import 'package:libcli/command/commands/shared/num.pbserver.dart';
import 'package:libcli/command/commands/shared/ping_action.pb.dart';
import 'package:libcli/command/commands/shared/ping_action.pbenum.dart';
import 'package:libcli/command/commands/shared/ping_action.pbjson.dart';
import 'package:libcli/command/commands/shared/ping_action.pbserver.dart';
import 'package:libcli/command/commands/shared/shared_service.pb.dart';
import 'package:libcli/command/commands/shared/text.pb.dart';
import 'package:libcli/command/commands/shared/text.pbenum.dart';
import 'package:libcli/command/commands/shared/text.pbjson.dart';
import 'package:libcli/command/commands/shared/text.pbserver.dart';
import 'package:libcli/command/commands/sys/analytics_action.pb.dart';
import 'package:libcli/command/commands/sys/analytics_action.pbenum.dart';
import 'package:libcli/command/commands/sys/analytics_action.pbjson.dart';
import 'package:libcli/command/commands/sys/analytics_action.pbserver.dart';
import 'package:libcli/command/commands/sys/sys_service.pb.dart';
import 'package:libcli/constant/contracts.dart';
import 'package:libcli/constant/events.dart';
import 'package:libcli/constant/preferences.dart';
import 'package:libcli/data/cookies.dart';
import 'package:libcli/data/data.dart';
import 'package:libcli/env/env.dart';
import 'package:libcli/error/error.dart';
import 'package:libcli/event_bus/event_bus.dart';
import 'package:libcli/log/color.dart';
import 'package:libcli/log/log.dart';
import 'package:libcli/tools/id.dart';
import 'package:libcli/tools/net.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
95
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
41
Learn more about scoring.

We analyzed this package on May 24, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.1
  • pana: 0.13.8-dev
  • Flutter: 1.17.0

Health suggestions

Fix lib/command/command.dart. (-0.50 points)

Analysis of lib/command/command.dart reported 1 hint:

line 125 col 8: The member 'mockInit' can only be used within 'package:libcli/data/data.dart' or a test.

Fix lib/command/commands/google/any.pb.dart. (-0.50 points)

Analysis of lib/command/commands/google/any.pb.dart reported 1 hint:

line 13 col 8: Don't import implementation files from another package.

Fix lib/command/commands/google/duration.pb.dart. (-0.50 points)

Analysis of lib/command/commands/google/duration.pb.dart reported 1 hint:

line 14 col 8: Don't import implementation files from another package.

Fix additional 68 files with analysis or formatting issues. (-3.50 points)

Additional issues in the following files:

  • lib/command/commands/google/field_mask.pb.dart (1 hint)
  • lib/command/commands/google/struct.pb.dart (1 hint)
  • lib/command/commands/google/timestamp.pb.dart (1 hint)
  • lib/command/commands/google/wrappers.pb.dart (1 hint)
  • lib/data/data.dart (1 hint)
  • lib/error/error.dart (1 hint)
  • lib/log/log.dart (1 hint)
  • lib/command/commands/google/any.pbenum.dart (Run flutter format to format lib/command/commands/google/any.pbenum.dart.)
  • lib/command/commands/google/any.pbjson.dart (Run flutter format to format lib/command/commands/google/any.pbjson.dart.)
  • lib/command/commands/google/any.pbserver.dart (Run flutter format to format lib/command/commands/google/any.pbserver.dart.)
  • lib/command/commands/google/api.pb.dart (Run flutter format to format lib/command/commands/google/api.pb.dart.)
  • lib/command/commands/google/api.pbenum.dart (Run flutter format to format lib/command/commands/google/api.pbenum.dart.)
  • lib/command/commands/google/api.pbjson.dart (Run flutter format to format lib/command/commands/google/api.pbjson.dart.)
  • lib/command/commands/google/api.pbserver.dart (Run flutter format to format lib/command/commands/google/api.pbserver.dart.)
  • lib/command/commands/google/descriptor.pb.dart (Run flutter format to format lib/command/commands/google/descriptor.pb.dart.)
  • lib/command/commands/google/descriptor.pbenum.dart (Run flutter format to format lib/command/commands/google/descriptor.pbenum.dart.)
  • lib/command/commands/google/descriptor.pbjson.dart (Run flutter format to format lib/command/commands/google/descriptor.pbjson.dart.)
  • lib/command/commands/google/descriptor.pbserver.dart (Run flutter format to format lib/command/commands/google/descriptor.pbserver.dart.)
  • lib/command/commands/google/duration.pbenum.dart (Run flutter format to format lib/command/commands/google/duration.pbenum.dart.)
  • lib/command/commands/google/duration.pbjson.dart (Run flutter format to format lib/command/commands/google/duration.pbjson.dart.)
  • lib/command/commands/google/duration.pbserver.dart (Run flutter format to format lib/command/commands/google/duration.pbserver.dart.)
  • lib/command/commands/google/empty.pb.dart (Run flutter format to format lib/command/commands/google/empty.pb.dart.)
  • lib/command/commands/google/empty.pbenum.dart (Run flutter format to format lib/command/commands/google/empty.pbenum.dart.)
  • lib/command/commands/google/empty.pbjson.dart (Run flutter format to format lib/command/commands/google/empty.pbjson.dart.)
  • lib/command/commands/google/empty.pbserver.dart (Run flutter format to format lib/command/commands/google/empty.pbserver.dart.)
  • lib/command/commands/google/field_mask.pbenum.dart (Run flutter format to format lib/command/commands/google/field_mask.pbenum.dart.)
  • lib/command/commands/google/field_mask.pbjson.dart (Run flutter format to format lib/command/commands/google/field_mask.pbjson.dart.)
  • lib/command/commands/google/field_mask.pbserver.dart (Run flutter format to format lib/command/commands/google/field_mask.pbserver.dart.)
  • lib/command/commands/google/googleProto_service.pb.dart (Run flutter format to format lib/command/commands/google/googleProto_service.pb.dart.)
  • lib/command/commands/google/source_context.pb.dart (Run flutter format to format lib/command/commands/google/source_context.pb.dart.)
  • lib/command/commands/google/source_context.pbenum.dart (Run flutter format to format lib/command/commands/google/source_context.pbenum.dart.)
  • lib/command/commands/google/source_context.pbjson.dart (Run flutter format to format lib/command/commands/google/source_context.pbjson.dart.)
  • lib/command/commands/google/source_context.pbserver.dart (Run flutter format to format lib/command/commands/google/source_context.pbserver.dart.)
  • lib/command/commands/google/struct.pbenum.dart (Run flutter format to format lib/command/commands/google/struct.pbenum.dart.)
  • lib/command/commands/google/struct.pbjson.dart (Run flutter format to format lib/command/commands/google/struct.pbjson.dart.)
  • lib/command/commands/google/struct.pbserver.dart (Run flutter format to format lib/command/commands/google/struct.pbserver.dart.)
  • lib/command/commands/google/timestamp.pbenum.dart (Run flutter format to format lib/command/commands/google/timestamp.pbenum.dart.)
  • lib/command/commands/google/timestamp.pbjson.dart (Run flutter format to format lib/command/commands/google/timestamp.pbjson.dart.)
  • lib/command/commands/google/timestamp.pbserver.dart (Run flutter format to format lib/command/commands/google/timestamp.pbserver.dart.)
  • lib/command/commands/google/type.pb.dart (Run flutter format to format lib/command/commands/google/type.pb.dart.)
  • lib/command/commands/google/type.pbenum.dart (Run flutter format to format lib/command/commands/google/type.pbenum.dart.)
  • lib/command/commands/google/type.pbjson.dart (Run flutter format to format lib/command/commands/google/type.pbjson.dart.)
  • lib/command/commands/google/type.pbserver.dart (Run flutter format to format lib/command/commands/google/type.pbserver.dart.)
  • lib/command/commands/google/wrappers.pbenum.dart (Run flutter format to format lib/command/commands/google/wrappers.pbenum.dart.)
  • lib/command/commands/google/wrappers.pbjson.dart (Run flutter format to format lib/command/commands/google/wrappers.pbjson.dart.)
  • lib/command/commands/google/wrappers.pbserver.dart (Run flutter format to format lib/command/commands/google/wrappers.pbserver.dart.)
  • lib/command/commands/shared/err.pb.dart (Run flutter format to format lib/command/commands/shared/err.pb.dart.)
  • lib/command/commands/shared/err.pbenum.dart (Run flutter format to format lib/command/commands/shared/err.pbenum.dart.)
  • lib/command/commands/shared/err.pbjson.dart (Run flutter format to format lib/command/commands/shared/err.pbjson.dart.)
  • lib/command/commands/shared/err.pbserver.dart (Run flutter format to format lib/command/commands/shared/err.pbserver.dart.)
  • lib/command/commands/shared/num.pb.dart (Run flutter format to format lib/command/commands/shared/num.pb.dart.)
  • lib/command/commands/shared/num.pbenum.dart (Run flutter format to format lib/command/commands/shared/num.pbenum.dart.)
  • lib/command/commands/shared/num.pbjson.dart (Run flutter format to format lib/command/commands/shared/num.pbjson.dart.)
  • lib/command/commands/shared/num.pbserver.dart (Run flutter format to format lib/command/commands/shared/num.pbserver.dart.)
  • lib/command/commands/shared/ping_action.pb.dart (Run flutter format to format lib/command/commands/shared/ping_action.pb.dart.)
  • lib/command/commands/shared/ping_action.pbenum.dart (Run flutter format to format lib/command/commands/shared/ping_action.pbenum.dart.)
  • lib/command/commands/shared/ping_action.pbjson.dart (Run flutter format to format lib/command/commands/shared/ping_action.pbjson.dart.)
  • lib/command/commands/shared/ping_action.pbserver.dart (Run flutter format to format lib/command/commands/shared/ping_action.pbserver.dart.)
  • lib/command/commands/shared/shared_service.pb.dart (Run flutter format to format lib/command/commands/shared/shared_service.pb.dart.)
  • lib/command/commands/shared/text.pb.dart (Run flutter format to format lib/command/commands/shared/text.pb.dart.)
  • lib/command/commands/shared/text.pbenum.dart (Run flutter format to format lib/command/commands/shared/text.pbenum.dart.)
  • lib/command/commands/shared/text.pbjson.dart (Run flutter format to format lib/command/commands/shared/text.pbjson.dart.)
  • lib/command/commands/shared/text.pbserver.dart (Run flutter format to format lib/command/commands/shared/text.pbserver.dart.)
  • lib/command/commands/sys/analytics_action.pb.dart (Run flutter format to format lib/command/commands/sys/analytics_action.pb.dart.)
  • lib/command/commands/sys/analytics_action.pbenum.dart (Run flutter format to format lib/command/commands/sys/analytics_action.pbenum.dart.)
  • lib/command/commands/sys/analytics_action.pbjson.dart (Run flutter format to format lib/command/commands/sys/analytics_action.pbjson.dart.)
  • lib/command/commands/sys/analytics_action.pbserver.dart (Run flutter format to format lib/command/commands/sys/analytics_action.pbserver.dart.)
  • lib/command/commands/sys/sys_service.pb.dart (Run flutter format to format lib/command/commands/sys/sys_service.pb.dart.)

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and libcli.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
fixnum ^0.10.11 0.10.11
flutter 0.0.0
http ^0.12.0 0.12.1
meta ^1.1.8 1.1.8
protobuf ^1.0.1 1.0.1
shared_preferences ^0.5.6+2 0.5.7+3
Transitive dependencies
charcode 1.1.3
collection 1.14.12
flutter_web_plugins 0.0.0
http_parser 3.1.4
path 1.7.0
pedantic 1.9.0
shared_preferences_macos 0.0.1+9
shared_preferences_platform_interface 1.0.4
shared_preferences_web 0.1.2+7
sky_engine 0.0.99
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test