lee_music_player 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 50

lee_music_player #

A new flutter plugin project.

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

0.0.1 #

  • TODO: Describe initial release.

example/lib/main.dart

import 'package:lee_music_player_example/directory_screen.dart';
import 'package:lee_music_player_example/example_animation_player.dart';
import 'package:lee_music_player_example/example_framing.dart';
import 'package:lee_music_player_example/example_layout_overlay.dart';
import 'package:lee_music_player_example/example_radial_drag.dart';
import 'package:flutter/material.dart';

void main() => runApp(new MyApp());

class MyApp extends StatelessWidget {
	@override
	Widget build(BuildContext context) {
		return new MaterialApp(
			title: 'Fluttery Example',
			theme: new ThemeData(
				primarySwatch: Colors.blue,
			),
			routes: {
				'/': (context) => new Page(
					child: new DirectoryScreen(),
				),
				'/randomColorBlock': (context) => new Page(
					child: new RandomColorBlockExampleScreen(),
				),
				'/layoutOverlay': (context) => new Page(
					child: new LayoutOverlayExampleScreen(),
				),
				'/radialDrag': (context) => new Page(
					child: new RadialDragExampleScreen(),
				),
				'/animationPlayer': (context) => new Page(
					child: new AnimationPlayerExampleScreen(),
				),
			},
		);
	}
}

class Page extends StatefulWidget {
	
	final child;
	
	Page({
		this.child,
	});
	
	@override
	_PageState createState() => new _PageState();
}

class _PageState extends State<Page> {
	@override
	Widget build(BuildContext context) {
		return new Scaffold(
			appBar: new AppBar(
				title: new Text('Fluttery'),
			),
			body: widget.child,
		);
	}
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  lee_music_player: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:lee_music_player/lee_music_player.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
12
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Mar 31, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Health suggestions

Format lib/animations.dart.

Run flutter format to format lib/animations.dart.

Format lib/gestures.dart.

Run flutter format to format lib/gestures.dart.

Format lib/layout.dart.

Run flutter format to format lib/layout.dart.

Fix additional 5 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/lee_music_player.dart (Run flutter format to format lib/lee_music_player.dart.)
  • lib/src/animation_player.dart (Run flutter format to format lib/src/animation_player.dart.)
  • lib/src/layout_core.dart (Run flutter format to format lib/src/layout_core.dart.)
  • lib/src/layout_overlays.dart (Run flutter format to format lib/src/layout_overlays.dart.)
  • lib/src/radial_drag_gesture_detector.dart (Run flutter format to format lib/src/radial_drag_gesture_detector.dart.)

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test