lee_music 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 43

lee_music #

A new flutter plugin project.

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

0.0.1 #

  • TODO: Describe initial release.

example/README.md

lee_music_example #

Demonstrates how to use the lee_music plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  lee_music: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:lee_music/lee_music.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
96
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
43
Learn more about scoring.

We analyzed this package on Jan 16, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health suggestions

Fix lib/_playlist.dart. (-1.99 points)

Analysis of lib/_playlist.dart reported 4 hints:

line 30 col 18: 'ancestorStateOfType' is deprecated and shouldn't be used. Use findAncestorStateOfType instead. This feature was deprecated after v1.12.1..

line 30 col 42: 'TypeMatcher' is deprecated and shouldn't be used. TypeMatcher has been deprecated because it is no longer used in framework(only in deprecated methods). This feature was deprecated after v1.12.1..

line 86 col 20: This function has a return type of 'Widget', but doesn't end with a return statement.

line 114 col 18: 'inheritFromWidgetOfExactType' is deprecated and shouldn't be used. Use dependOnInheritedWidgetOfExactType instead. This feature was deprecated after v1.12.1..

Fix lib/_audio_player_widgets.dart. (-1 points)

Analysis of lib/_audio_player_widgets.dart reported 2 hints:

line 8 col 31: 'ancestorStateOfType' is deprecated and shouldn't be used. Use findAncestorStateOfType instead. This feature was deprecated after v1.12.1..

line 8 col 55: 'TypeMatcher' is deprecated and shouldn't be used. TypeMatcher has been deprecated because it is no longer used in framework(only in deprecated methods). This feature was deprecated after v1.12.1..

Fix lib/_audio_player.dart. (-0.50 points)

Analysis of lib/_audio_player.dart reported 1 hint:

line 26 col 32: This function has a return type of 'Future', but doesn't end with a return statement.

Fix additional 8 files with analysis or formatting issues. (-0.50 points)

Additional issues in the following files:

  • lib/_audio_visualizer.dart (1 hint)
  • lib/_visualizer.dart (Run flutter format to format lib/_visualizer.dart.)
  • lib/animation/animation_player.dart (Run flutter format to format lib/animation/animation_player.dart.)
  • lib/animation/gestures.dart (Run flutter format to format lib/animation/gestures.dart.)
  • lib/animation/layout_core.dart (Run flutter format to format lib/animation/layout_core.dart.)
  • lib/animation/layout_overlays.dart (Run flutter format to format lib/animation/layout_overlays.dart.)
  • lib/animation/radial_drag_gesture_detector.dart (Run flutter format to format lib/animation/radial_drag_gesture_detector.dart.)
  • lib/lee_music.dart (Run flutter format to format lib/lee_music.dart.)

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test