lcfarm_flutter_umeng 0.1.7

  • Readme
  • Changelog
  • Example
  • Installing
  • 80

lcfarm_flutter_umeng #

A new flutter plugin project.

Getting Started #

android项目需要在MainActivity.java添加方法

  public void onResume() {
    super.onResume();
    MobclickAgent.onResume(this);

  }

  public void onPause() {
    super.onPause();
    MobclickAgent.onPause(this);
  }

当然记得引入

import com.umeng.analytics.MobclickAgent;

0.1.7 #

android 多渠道

0.1.6 #

android 渠道调整。 不传channel ,则读取androidmanifest.xml

0.1.5 #

iOS支持swift

0.1.4 #

android才有效

  • onResume
  • onPause

友盟的android插件用的是8.0以下的 iOS使用没有设置友盟插件版本号

example/README.md

lcfarm_flutter_umeng_example #

Demonstrates how to use the lcfarm_flutter_umeng plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  lcfarm_flutter_umeng: ^0.1.7

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:lcfarm_flutter_umeng/lcfarm_flutter_umeng.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
59
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
80
Learn more about scoring.

We analyzed this package on Oct 18, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test