lamp 0.0.6

  • Readme
  • Changelog
  • Example
  • Installing
  • 88

Lamp #

pub package A Flutter plugin to access the device's lamp/torch on Android and iOS.

Usage #

To use this plugin, add lamp as a dependency in your pubspec.yaml file.

For android, add the following to your manifest

<uses-permission android:name="android.permission.CAMERA" />
<uses-permission android:name="android.permission.FLASHLIGHT" />
<uses-feature android:name="" />
<uses-feature android:name="" />
<uses-feature android:name="" />

Example #

// Import package
import 'package:lamp/lamp.dart';

// Turn the lamp on:

// Turn the lamp off:

// Turn the lamp with a specific intensity (only affects iOS as of now):
Lamp.turnOn(intensity: 0.4);

// Check if the device has a lamp:
bool hasLamp = await Lamp.hasLamp;

[0.0.6] - August 22, 2018

  • Adjust pubspec.yml to match Dart 2.0 SDK version

[0.0.5] - May 10th, 2018.

Implement flashing for duration

[0.0.4] - May 7th, 2018.

Fix syntax error

[0.0.3] - May 6th, 2018.

Fix Dart 2.0 compatibility

[0.0.1] - January 23rd, 2018.

  • Initial release


import 'package:flutter/material.dart';
import 'package:lamp/lamp.dart';
import 'dart:async';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
  _MyAppState createState() => new _MyAppState();

class _MyAppState extends State<MyApp> {
  bool _hasFlash = false;
  bool _isOn = false;
  double _intensity = 1.0;

  initState() {

  initPlatformState() async {
    bool hasFlash = await Lamp.hasLamp;
    print("Device has flash ? $hasFlash");
    setState(() { _hasFlash = hasFlash; });

  Widget build(BuildContext context) {
    return new MaterialApp(
      theme: new ThemeData(primarySwatch:,
      home: new Scaffold(
        appBar: new AppBar(title: new Text('Lamp plugin example')),
        body: new Center(
          child: new Column(
              children: <Widget>[
            new Text('Device has flash: $_hasFlash\n Flash is on: $_isOn'),
            new Slider(value: _intensity, onChanged: _isOn ? _intensityChanged : null),
            new RaisedButton(onPressed: () async => await Lamp.flash(new Duration(seconds: 2)), child:  new Text("Flash for 2 seconds"))
        floatingActionButton: new FloatingActionButton(
          child: new Icon(_isOn ? Icons.flash_off : Icons.flash_on),
          onPressed: _turnFlash),

  Future _turnFlash() async {
    _isOn ? Lamp.turnOff() : Lamp.turnOn(intensity: _intensity);
    var f = await Lamp.hasLamp;
      _hasFlash = f;
      _isOn = !_isOn;

  _intensityChanged(double intensity) {
    Lamp.turnOn(intensity : intensity);
      _intensity = intensity;


Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  lamp: ^0.0.6

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:lamp/lamp.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Oct 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

7 out of 7 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/lamp.dart.

Run flutter format to format lib/lamp.dart.

Maintenance suggestions

Package is getting outdated. (-15.07 points)

The package was last published 60 weeks ago.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8