koukicons 2.0.3
koukicons: ^2.0.3 copied to clipboard

Colorful Icons for your Flutter App, no more black and white icons

example/lib/main.dart

import 'package:flutter/material.dart';

// Import Icons
import 'package:koukicons/gift.dart';
import 'package:koukicons/like.dart';
import 'package:koukicons/star.dart';
import 'package:koukicons/pic2.dart';
import 'package:koukicons/diamond.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Flutter Demo',
      theme: ThemeData(
        primarySwatch: Colors.red,
      ),
      home: MyHomePage(title: 'Koukicons Demo'),
    );
  }
}

class MyHomePage extends StatefulWidget {
  MyHomePage({Key key, this.title}) : super(key: key);

  final String title;

  @override
  _MyHomePageState createState() => _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text(widget.title),
      ),
      body: Center(
        child: Column(
          mainAxisAlignment: MainAxisAlignment.center,
          children: <Widget>[
            Text('+700 Colorful Icons!', style: TextStyle(fontSize: 30)),
            Text('No more black & white icons', style: TextStyle(fontSize:16)),
            SizedBox(
              height: 10,
            ),
            Row(
              mainAxisAlignment: MainAxisAlignment.center,
              children: <Widget>[
                KoukiconsGift(),
                KoukiconsLike(),
                KoukiconsStar(),
                KoukiconsPic2(),
              ],
            ),
            SizedBox(
              height: 10,
            ),
            KoukiconsDiamond(height: 100,),
          ],
        ),
      ),
    );
  }
}
80
likes
75
pub points
80%
popularity

Colorful Icons for your Flutter App, no more black and white icons

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, flutter_svg

More

Packages that depend on koukicons