kokoroio 0.4.0

  • Readme
  • Changelog
  • Installing
  • 46

kokoroio.dart #

0.4.0 #

  • Added stream

0.3.1 #

  • fixed export

0.3.0 #

  • Added getChannelsMessages

0.2.2 #

  • added utf8 encoding

0.2.1 #

  • fixed typo

0.2.0 #

  • Added getMemberships

0.1.1 #

  • Fix library import

0.1.0 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  kokoroio: ^0.4.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:kokoroio/kokoroio.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Analysis suggestions

Package not compatible with runtime flutter-web on web

Because of the import of dart:io via the import chain package:kokoroio/kokoroio.dartpackage:kokoroio/src/kokoroio_stream.dartdart:io

Package not compatible with runtime web

Because of the import of dart:io via the import chain package:kokoroio/kokoroio.dartpackage:kokoroio/src/kokoroio_stream.dartdart:io

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and kokoroio.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
http ^0.12.0 0.12.1
json_annotation ^3.0.1 3.0.1
json_serializable ^3.2.5 3.3.0
Transitive dependencies
_fe_analyzer_shared 5.0.0
analyzer 0.39.12
args 1.6.0
async 2.4.2
build 1.3.0
build_config 0.4.2
charcode 1.1.3
checked_yaml 1.0.2
collection 1.14.13 1.15.0-nnbd
convert 2.1.1
crypto 2.1.5
csslib 0.16.1
dart_style 1.3.6
glob 1.2.0
html 0.14.0+3
http_parser 3.1.4
js 0.6.2
logging 0.11.4
meta 1.2.1
node_interop 1.1.1
node_io 1.1.1
package_config 1.9.3
path 1.7.0
pub_semver 1.4.4
pubspec_parse 0.1.5
source_gen 0.9.5
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.2.0 1.3.0-nnbd
watcher 0.9.7+15
yaml 2.2.1
Dev dependencies
build_runner ^1.8.0
pedantic ^1.8.0 1.9.1
test ^1.6.0