kernel 0.3.2

  • Installing
  • Versions
  • 48

Dart Kernel #

Dart Kernel is a small high-level language derived from Dart. It is designed for use as an intermediate format for whole-program analysis and transformations, and as a frontend for codegen and execution backends.

The kernel language has in-memory representations in Dart and C++, and can be serialized as binary or text.

Both the kernel language and its implementations are unstable and are under development.

This package contains the Dart part of the implementation and contains:

  • A transformable IR for the kernel language
  • A frontend based on the analyzer
  • Serialization of kernel code

Note: The APIs in this package are in an early state; developers should be careful about depending on this package. In particular, there is no semver contract for release versions of this package. Please depend directly on individual versions.

Getting Kernel #

Checkout the repository and run pub get:

git clone
cd kernel
pub get

Command-Line Tool #

Run tool/dartk.dart from the command-line to convert between .dart files and the serialized binary and textual formats.

dartk expects the .dill extension for files in the binary format. The textual format has no preferred extension right now.

Example commands:

dartk foo.dart            # print text IR for foo.dart
dartk foo.dart -ofoo.dill # write binary IR for foo.dart to foo.dill
dartk foo.dill            # print text IR for binary file foo.dill

Pass the --link or -l flag to link all transitive dependencies into one file:

dartk myapp.dart -ppackages -l -omyapp.dill # Bundle everything.
dartk myapp.dill # Print it back out in a (very, very long) textual format.

See ast.dart for the in-memory IR, or for a description of the binary format. For now, the textual format is very ad-hoc and cannot be parsed back in.

Testing #

If you plan to make changes to kernel, get a checkout of the Dartk SDK and run:

tool/regenerate_dill_files.dart --sdk <path to SDK checkout>
pub run test

Linking #

Linking from binary files is not yet implemented. In order to compile a whole program, currently everything must be compiled from source at once.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  kernel: ^0.3.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:kernel/kernel.dart';
Version Uploaded Documentation Archive
0.3.18 May 3, 2019 Go to the documentation of kernel 0.3.18 Download kernel 0.3.18 archive
0.3.17 Apr 24, 2019 Go to the documentation of kernel 0.3.17 Download kernel 0.3.17 archive
0.3.16 Apr 22, 2019 Go to the documentation of kernel 0.3.16 Download kernel 0.3.16 archive
0.3.15 Mar 21, 2019 Go to the documentation of kernel 0.3.15 Download kernel 0.3.15 archive
0.3.14 Mar 15, 2019 Go to the documentation of kernel 0.3.14 Download kernel 0.3.14 archive
0.3.13 Feb 28, 2019 Go to the documentation of kernel 0.3.13 Download kernel 0.3.13 archive
0.3.12 Feb 22, 2019 Go to the documentation of kernel 0.3.12 Download kernel 0.3.12 archive
0.3.11 Feb 12, 2019 Go to the documentation of kernel 0.3.11 Download kernel 0.3.11 archive
0.3.10 Jan 29, 2019 Go to the documentation of kernel 0.3.10 Download kernel 0.3.10 archive
0.3.9+1 Feb 1, 2019 Go to the documentation of kernel 0.3.9+1 Download kernel 0.3.9+1 archive

All 43 versions...

Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.48.0 <2.0.0