kdb 0.1.2

dart-kdb #

Driver for kx.com database (kdb+). Implements some viable set of functionality.

types #

  • ints are serialized as bytes/shorts/ints/longs depending on range (signed).
  • char arrays (strings), chars, syms are deserialized as strings, serialized as syms.
  • dates,timestamps are deserialized as DateTime with millisecond precision, serialized as -15(dateTtime).
  • floats and doubles are deserialized as doubles. Serialized as doubles.

usage #

  var conn = new c();
  await conn.connect("localhost", 5000);
  var five = await conn.exec("2j+3j");
  var fifteen = await conn.execFun("{x+y}",[z, 10]);
  await conn.close()

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  kdb: ^0.1.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

Popularity:
Describes how popular the package is relative to other packages. [more]
11
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
6
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1