junitconfiguration 1.2.0

JUnit Configuration #

A test configuration producing JUnit compatible output. This is useful for continuous integration servers (such as Jenkins) that support displaying JUnit test results.

This library is open source, stable and well tested. Development happens on GitHub. Feel free to report issues or create a pull-request there. The most recent stable versions are available through pub.dartlang.org.

Continuous build results are available from Jenkins.

Installation and Use #

Add the dependency to your package's pubspec.yaml file:

dependencies:
  junitconfiguration: ">=1.0.0 <2.0.0"

Then on the command line run:

$ pub get

To import the package into your Dart tests add:

import 'package:junitconfiguration/junitconfiguration.dart';

At the top of your main method, before the actual tests write:

JUnitConfiguration.install();

And this is all that is needed.

Misc #

License #

The MIT License, see LICENSE.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  junitconfiguration: ^1.2.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:junitconfiguration/junitconfiguration.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

This package is not analyzed, because it is discontinued.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0