json_object_convert 0.0.2

  • Readme
  • Changelog
  • Installing
  • 29

w# json_object_convert

A new flutter package project.

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  json_object_convert: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:json_object_convert/json_object_convert.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
97
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
29
Learn more about scoring.

We analyzed this package on Jan 17, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.2

Health suggestions

Fix lib/src/hook/hook.dart. (-3.45 points)

Analysis of lib/src/hook/hook.dart reported 7 hints, including:

line 11 col 3: Omit type annotations for local variables.

line 41 col 15: Unnecessary new keyword.

line 42 col 13: Prefer single quotes where they won't require escape sequences.

line 45 col 7: Omit type annotations for local variables.

line 46 col 7: Omit type annotations for local variables.

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (analyzer, build).

Use constrained dependencies. (-20 points)

The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: json_object_convert_help.

Package is getting outdated. (-24.38 points)

The package was last published 64 weeks ago.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and json_object_convert.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
analyzer ^0.32.0 0.32.6 0.39.4
build ^0.12.0 0.12.8 1.2.2
jaguar_orm ^2.2.5 2.2.7
jaguar_query ^2.2.4 2.2.9
json_object_convert_help any 0.0.1
logging ^0.11.0 0.11.4
meta ^1.1.5 1.1.8
source_gen ^0.9.0 0.9.1+3 0.9.4+7
Transitive dependencies
args 1.5.2
async 2.4.0
charcode 1.1.2
convert 2.1.1
crypto 2.1.4
csslib 0.16.1
dart_style 1.1.3 1.3.3
front_end 0.1.4+2 0.1.29
glob 1.2.0
html 0.14.0+3
js 0.6.1+1
kernel 0.3.4+2 0.3.29
matcher 0.12.6
node_interop 1.0.3
node_io 1.0.1+2
package_config 1.1.0
pedantic 1.9.0
plugin 0.2.0+3
quiver 2.1.2+1
source_span 1.6.0
stack_trace 1.9.3
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+13
yaml 2.2.0
Dev dependencies
build_runner ^0.10.0
build_test ^0.10.3
collection ^1.14.10 1.14.12
path ^1.6.2 1.6.4
test ^1.3.0