json_compressor 1.0.0

  • README.md
  • Installing
  • Versions
  • 0

json_compressor #

provides a transformer that compresses json files

Usage #

json_compressor provides two parameters: 'debugMode' and 'prodMode', both are optional.

  json_compressor: ^1.0.0
- json_compressor:
    debugMode: indent1
    prodMode: no_indent

possible values (for both) #

  • off: don't change the json files (this is also the fallback, if an illegal value was provided)
  • single_row: compress json file to a singleline version without spaces or newlines
  • no_indent: compress json file to a multiline version without indentation/spaces
  • indent1: compress json file to a multiline version with one space indentation per level
  • indent2: compress json file to a multiline version with two spaces indentation per level
  • indent4: compress json file to a multiline version with four spaces indentation per level

default values #

  • debugMode: no_indent
  • prodMode: single_row

Changelog #

1.0.0 #

  • Initial version with a functional json compressing transformer

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  json_compressor: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:json_compressor/transformer.dart';
Version Uploaded Documentation Archive
1.0.0 Feb 5, 2017 Go to the documentation of json_compressor 1.0.0 Download json_compressor 1.0.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.12.0 <2.0.0