json2dart 1.0.2

  • README.md
  • Installing
  • Versions
  • 0

json2dart #

Generates Dart classes from JSON.

Installation #

pub global activate json2dart

Usage #

From the command-line:

json2dart foo.json >> foo.dart
json2dart --owl bar.json >> bar.dart # Generate `package:owl_codegen` metadata as well
json2dart -c ArbitraryClassName baz.json >> arbitrary.dart

This package also supports a package:build builder in package:json2dart/builder.dart.

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate json2dart

2. Use it

The package has the following executables:


$ json2dart

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  json2dart: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:json2dart/json2dart.dart';
  
Version Uploaded Documentation Archive
1.0.2 Mar 11, 2017 Go to the documentation of json2dart 1.0.2 Download json2dart 1.0.2 archive
1.0.1 Mar 11, 2017 Go to the documentation of json2dart 1.0.1 Download json2dart 1.0.1 archive
1.0.0 Mar 6, 2017 Go to the documentation of json2dart 1.0.0 Download json2dart 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0