js 0.6.5 icon indicating copy to clipboard operation
js: ^0.6.5 copied to clipboard

Platformweb

Annotations to create static Dart interfaces for JavaScript APIs.

0.6.5 #

  • Populate the pubspec repository field.
  • Add a dependency on package:meta.
  • Add an experimental @trustTypes annotation.

0.6.4 #

  • Includes @staticInterop to allow interop with native types from dart:html.

0.6.3 #

  • Stable release for null safety.

0.6.3-nullsafety.3 #

  • Update SDK constraints to >=2.12.0-0 <3.0.0 based on beta release guidelines.

0.6.3-nullsafety.2 #

  • Allow prerelease versions of the 2.12 sdk.

0.6.3-nullsafety.1 #

  • Allow 2.10 stable and 2.11.0 dev SDK versions.

0.6.3-nullsafety #

  • Opt in to null safety.

0.6.2 #

  • Improved documentation.

0.6.1+1 #

  • Support Dart 2 final release.

0.6.1 #

  • Add js_util library of utility methods to efficiently manipulate typed JavaScript interop objects in cases where the member name is not known statically.

0.6.0 #

  • Version 0.6.0 is a complete rewrite of package:js.
263
likes
140
pub points
99%
popularity

Publisher

verified publisher icondart.dev

Annotations to create static Dart interfaces for JavaScript APIs.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

meta

More

Packages that depend on js