joystick 1.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • new64

joystick #

A joystick widget for Flutter your apps.

It's design can be customized like background/icon color or opacity.

To set this joystick draggable is optional.

You can also use only vertical or horizontal direction arrows instead of all direction arrows.

Preview

[1.0.2] #

  • Animated GIF is added for ReadMe

[1.0.1] #

  • ReadMe is updated

[1.0.0] #

  • Migrated to stable version and a bug is fixed

[0.0.9] #

  • First initial release.

example/README.md

Example usage

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  joystick: ^1.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:joystick/joystick.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
28
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
64
Learn more about scoring.

We analyzed this package on Feb 26, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.8

Health suggestions

Format lib/joystick.dart.

Run flutter format to format lib/joystick.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test