jlogger 0.0.7

  • Readme
  • Changelog
  • Example
  • Installing
  • 59

jlogger #

Simple Flutter Console Logger

Getting Started #


JLogger.log('We Are Here');

Console Output #

html

[0.0.7] - TODO: Add release date. #

  • Cleanup

[0.0.6] - TODO: Add release date. #

  • Fixed Example Wrong Directory

[0.0.5] - TODO: Add release date. #

  • Added Example

[0.0.4] - TODO: Add release date. #

  • fixed : error thrown when called inside main function

[0.0.3] - TODO: Add release date. #

  • BugFix

[0.0.2] - TODO: Add release date. #

  • Bug fix

[0.0.1] - TODO: Add release date. #

  • TODO: Describe initial release.

example/main.dart

import 'package:jlogger/jlogger.dart';

import '_ClassA.dart';


void main()
{
	JLogger.log('This is Simple Readable And Easly Traceable Log');

	A a = A();

	a.showLog();

	a.showDeepLogA();
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  jlogger: ^0.0.7

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:jlogger/jlogger.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
22
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
59
Learn more about scoring.

We analyzed this package on Feb 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.8

Health suggestions

Format lib/jlogger.dart.

Run flutter format to format lib/jlogger.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test