jikan 0.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 52

jikan-dart #

Dart wrapper for the Jikan RESTful API, the unofficial API for MyAnimeList's website. This wrapper allows asynchronous requests to the API and a strongly-typed model.

0.0.2 #

0.0.1 #

  • Initial proof-of-concept release.


import 'package:jikan/jikan.dart';

void main() async {
  Jikan jikan = Jikan();

  /// Fetches the anime "Sword Art Online: Alicization"
  Anime anime = await jikan.getAnime(id: 36474);

  /// Fetches the schedule for the anime airing this week
  jikan.getSchedule().then((schedule) => print(schedule.monday));

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  jikan: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:jikan/jikan.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Feb 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5

Health suggestions

Fix lib/src/jikan.dart. (-0.50 points)

Analysis of lib/src/jikan.dart reported 1 hint:

line 38 col 19: Unnecessary new keyword.

Fix lib/src/model.dart. (-0.50 points)

Analysis of lib/src/model.dart reported 1 hint:

line 318 col 18: Unnecessary new keyword.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (json_annotation).

Package is getting outdated. (-19.18 points)

The package was last published 62 weeks ago.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.58.0 <3.0.0
http ^0.12.0 0.12.0+4
json_annotation ^2.0.0 2.4.0 3.0.1
meta ^1.1.6 1.1.8
Transitive dependencies
async 2.4.0
charcode 1.1.3
collection 1.14.12
http_parser 3.1.3
path 1.6.4
pedantic 1.9.0
source_span 1.6.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
build_runner ^1.0.0
build_verify ^1.0.0
json_serializable ^2.0.0
test ^1.3.3