jaguar_static_file 0.5.5

jaguar_static_file #

Provides two ways to serve static files

  1. StaticFileHandler : RequestHandler based
  2. StaticFile : Interceptor based

StaticFileHandler #

StaticFileHandler is RequestHandler based. It can be directly added to Jaguar server using addApi method or included in an Api using IncludeApi annotation.

Usage #

Future main() async {
  final server = new Jaguar();
      new StaticFileHandler('/public/*', new Directory('./example/static/')));
  await server.serve();

StaticFile #

StaticFile is an interceptor that substituted JaguarFile in response with actual content of the file JaguarFile (JaguarFile) points to.

Usage #

class MyApi extends _$MyApi {
  @Get(path: '/file')
  JaguarFile getFile(Context ctx) =>
      new JaguarFile(Directory.current.path + "/static/file.css");

  @Get(path: '/static/:filename*')
  JaguarFile getDir(Context ctx) => new JaguarFile(
      Directory.current.path + '/static/' + ctx.pathParams['filename']);

  StaticFile staticFile(Context ctx) => new StaticFile();

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  jaguar_static_file: ^0.5.5

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:jaguar_static_file/jaguar_static_file.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0