jaguar_session_mongo 0.0.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 5

jaguar_session_mongo #

MongoDb based session manager for Jaguar.dart. Stores session data in a MongoDb collection

Changelog #

0.0.1 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  jaguar_session_mongo: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:jaguar_session_mongo/jaguar_session_mongo.dart';
  
Version Uploaded Documentation Archive
2.2.1 Aug 24, 2018 Go to the documentation of jaguar_session_mongo 2.2.1 Download jaguar_session_mongo 2.2.1 archive
2.2.0 Aug 15, 2018 Go to the documentation of jaguar_session_mongo 2.2.0 Download jaguar_session_mongo 2.2.0 archive
2.1.2 Jul 15, 2018 Go to the documentation of jaguar_session_mongo 2.1.2 Download jaguar_session_mongo 2.1.2 archive
2.1.1 Jul 12, 2018 Go to the documentation of jaguar_session_mongo 2.1.1 Download jaguar_session_mongo 2.1.1 archive
1.3.1 Feb 2, 2018 Go to the documentation of jaguar_session_mongo 1.3.1 Download jaguar_session_mongo 1.3.1 archive
1.2.6 Jan 13, 2018 Go to the documentation of jaguar_session_mongo 1.2.6 Download jaguar_session_mongo 1.2.6 archive
0.0.3 Jul 9, 2017 Go to the documentation of jaguar_session_mongo 0.0.3 Download jaguar_session_mongo 0.0.3 archive
0.0.2 Jul 3, 2017 Go to the documentation of jaguar_session_mongo 0.0.2 Download jaguar_session_mongo 0.0.2 archive
0.0.1 Jun 17, 2017 Go to the documentation of jaguar_session_mongo 0.0.1 Download jaguar_session_mongo 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
10
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
5
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0