jaguar_reflect_bootstrap 0.4.0

  • Example
  • Installing
  • Versions
  • 0

jaguar_reflect_bootstrap #

Bootstrapper for jaguar_reflect to automatically add Api from imported libraries

Usage #

A simple usage example:

  Jaguar server = new Jaguar();

Features and bugs #

Please file feature requests and bugs at the issue tracker.

Changelog #

0.0.1 #

  • Initial version, created by Stagehand


// Copyright (c) 2017, teja. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

import 'package:jaguar_reflect_bootstrap/jaguar_reflect_bootstrap.dart';
import 'package:jaguar/jaguar.dart';

class ExampleApi {}

class ExampleApi1 {}

main() {
  Jaguar server = new Jaguar();

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  jaguar_reflect_bootstrap: ^0.4.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:jaguar_reflect_bootstrap/jaguar_reflect_bootstrap.dart';
Version Uploaded Documentation Archive
0.4.0 Feb 19, 2017 Go to the documentation of jaguar_reflect_bootstrap 0.4.0 Download jaguar_reflect_bootstrap 0.4.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0