jaguar_martini 2.1.0-dev1

  • Readme
  • Changelog
  • Installing
  • 37

jaguar_martini #

Jekyll and Hugo like static site generator that uses right mix of Markdown, HTML and Dart

Roadmap #

High priority #

  • [X] Permalink
  • [ ] Sort tags by count
  • [ ] Sort categories by count
  • [ ] Table of content

On the loop #

  • [x] Generate single pages
  • [X] Generate lists
  • [X] Generate sections
  • [X] Generate categories
  • [X] Generate tags
  • [ ] List page pagination
  • [ ] Generate home page
  • [ ] Word counts
  • [ ] Reading time calculation
  • [ ] Post summary

In the future #

  • [ ] Multiple output formats
  • [ ] Translation
  • [ ] Slide show generation
  • [ ] Generate series

Changelog #

0.0.7 #

  • Home page

0.0.6 #

  • Page sorting (Untested)

0.0.5 #

  • Permalinks

0.0.4 #

  • Experimenting with static file serving

0.0.3 #

  • List page generation

0.0.2 #

  • Shortcode parsing

0.0.1 #

  • Markdown processing
  • Basic writer support

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  jaguar_martini: ^2.1.0-dev1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:jaguar_martini/jaguar_martini.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
81
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
65
Overall:
Weighted score of the above. [more]
37
Learn more about scoring.

We analyzed this package on Dec 10, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21

Health suggestions

Fix lib/core/builder.dart. (-4.89 points)

Analysis of lib/core/builder.dart reported 10 hints, including:

line 14 col 62: Use ; instead of {} for empty constructor bodies.

line 18 col 11: 'mergeAll' is deprecated and shouldn't be used. Use the extension instead.

line 19 col 18: 'debounce' is deprecated and shouldn't be used. Use the extension instead.

line 56 col 11: Use isNotEmpty instead of length

line 72 col 13: Use isNotEmpty instead of length

Fix lib/server/fs_writer.dart. (-3.45 points)

Analysis of lib/server/fs_writer.dart reported 7 hints, including:

line 38 col 13: Unnecessary new keyword.

line 41 col 13: Unnecessary new keyword.

line 44 col 23: Unnecessary new keyword.

line 51 col 18: Unnecessary new keyword.

line 53 col 11: Unnecessary new keyword.

Fix lib/core/composer/composer.dart. (-2.48 points)

Analysis of lib/core/composer/composer.dart reported 5 hints:

line 15 col 44: Unnecessary new keyword.

line 22 col 34: Unnecessary new keyword.

line 27 col 20: Unnecessary new keyword.

line 33 col 32: Unnecessary new keyword.

line 44 col 38: Unnecessary new keyword.

Fix additional 7 files with analysis or formatting issues. (-9.45 points)

Additional issues in the following files:

  • lib/server/gencon.dart (5 hints)
  • lib/models/models.dart (4 hints)
  • lib/models/site_meta.dart (4 hints)
  • lib/content_source/fs.dart (3 hints)
  • lib/models/post_meta.dart (2 hints)
  • lib/shortcode/shortcode.dart (1 hint)
  • lib/fs_content_source.dart (Run dartfmt to format lib/fs_content_source.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (rxdart, stream_transform).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and jaguar_martini.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-release. (-5 points)

Pre-release versions should be used with caution; their API can change in breaking ways.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
jaguar ^2.4.1 2.4.36
jaguar_cache ^2.1.2 2.1.2
markdown ^2.0.1 2.1.3
path ^1.6.1 1.6.4
rxdart ^0.18.0 0.18.1 0.22.6
stream_transform ^0.0.14 0.0.20 1.1.0
yaml ^2.1.12 2.2.0
Transitive dependencies
args 1.5.2
auth_header 2.1.4
charcode 1.1.2
collection 1.14.12
convert 2.1.1
crypto 2.1.4
http_server 0.9.8+3
jaguar_common 2.1.4
jaguar_serializer 2.2.12
logging 0.11.3+2
meta 1.1.8
mime 0.9.6+3
path_tree 2.2.2
source_span 1.5.5
stack_trace 1.9.3
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
stencil ^2.1.0
test ^1.2.0