io_extra 0.1.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 0

io_extra #

Extra io utilities for dartlang. Copy, Move, etc.

More features are on the way. Check the dev branch to see the newest commits.

Important #

  • All links are skipped.
  • All non-exists target folders would be created.
  • All exists targets (file or folder) would be overwritten.

Usage #

import 'dart:async';
import 'package:path/path.dart' as path;
import 'package:io_extra/io_extra.dart' as extra;

main() async {
  // File -> File
  extra.copySync('', path.join('targetFolder', ''));

  // File -> Folder
  await extra.copy('', path.join('basePath', 'targetFolder'));

  // Folder -> Folder
  extra.copySync('sourceFolder', path.join('basePath', 'not_exists_folder'));

Changelog #

0.1.0 #

  • Fix and republish the initial version.


import 'dart:io';

import 'package:path/path.dart' as path;
import 'package:io_extra/io_extra.dart' as extra;

main() async {
  // File -> File
  extra.copySync('', path.join('playground', 'targetFolder', ''));

  // File -> Folder
  await extra.copy('', path.join('playground', 'basePath', 'targetFolder'));

  // Folder -> Folder
  extra.copySync('sourceFolder', path.join('playground', 'basePath', 'not_exists_folder'));

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  io_extra: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:io_extra/io_extra.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0