intl_yaml 0.0.5

  • Readme
  • Changelog
  • Installing
  • 5

☠ Attention ☠

intl_yaml #

This package able to Auto implement intl globalization method from yaml.

Getting Started #

usage #

  1. install intl
    sdk: flutter
  1. create globalize yaml



make: 'Make'
stock: 'Stock'
  value: 'hello :user'
    user: 'Guest'


make: '作る'
stock: 'ストック'
  value: ':user さん、こんにちわ'
    user: 'ゲスト'
  1. execute
  --config-file 'select globalize file'
  --config-dir 'select globalize dir(ignore if use `--config-file`)'
  --out-lang-dir 'select dir to output the globalize method';
  --out-service-dir 'select dir to output the globalize service';
  --file-prefix 'globalize method file prefix (defailt: intl_message)';
  --default-locale 'default locale(default: en)';
  --project-name(-p) 'project name(temporary option)';

example #

flutter pub pub run \
bin/main.dart \
--config-dir example/lang \
--out-lang-dir example/configs \
--out-service-dir example/services \
--project-name intl_yaml

[0.0.4] - 2018/10/21

  • Update flutter 0.10.x.

[0.0.4] - 2018/10/6

  • Fixed a bug when installing as pubspec package.

[0.0.3] - 2018/10/6

  • Compatible Dart 2.0.

[0.0.2] - 2018/6/30

  • Update pubspec.

[0.0.1] - 2018/6/30

  • Initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  intl_yaml: ^0.0.5

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:intl_yaml/main.dart';
import 'package:intl_yaml/parser.dart';
import 'package:intl_yaml/stub.dart';
import 'package:intl_yaml/stub_file.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 17, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running flutter pub upgrade failed with the following output:

ERR: The current Flutter SDK version is 1.12.13+hotfix.5.
 Because intl_yaml requires Flutter SDK version >=0.9.0 <1.0.0, version solving failed.

Health suggestions

Format bin/main.dart.

Run flutter format to format bin/main.dart.

Format lib/main.dart.

Run flutter format to format lib/main.dart.

Format lib/parser.dart.

Run flutter format to format lib/parser.dart.

Format lib/stub.dart.

Run flutter format to format lib/stub.dart.

Format lib/stub_file.dart.

Run flutter format to format lib/stub_file.dart.

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Package is getting outdated. (-24.11 points)

The package was last published 64 weeks ago.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-9 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and intl_yaml.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0