intl 0.16.1
intl: ^0.16.1
intl: ^0.17.0-nullsafety.2

Dart native js
Flutter Android iOS web

Contains code to deal with internationalized/localized messages, date and number formatting and parsing, bi-directional text, and other internationalization issues.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  intl: ^0.16.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:intl/intl.dart';
840
likes
90
pub points
100%
popularity

Publisher

dart.dev

Contains code to deal with internationalized/localized messages, date and number formatting and parsing, bi-directional text, and other internationalization issues.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

path

More

Packages that depend on intl