interpolate 1.0.2+2

  • Readme
  • Changelog
  • Example
  • Installing
  • 76

interpolate #

A dart plugin to interpolate range of values

Usage #

import 'package:interpolate/interpolate.dart';

Interpolate interpolate = Interpolate(
    inputRange: [10, 20, 30],
    outputRange: [1, 0, 1],
    extrapolate: Extrapolate.clamp,
);
interpolate.eval(15); // returns 0.5

NOTE #

The inputRange have to be increasing else it might not get the expected result of might throw an error or returns null; The length of the outputRange have to be equal to the output range

The Extrapolate Enum #

enum Extrapolate {
  extend, // No clamping
  clamp, // Clamps both ends
  clampStart, // clamps the value to the start and extend the end
  clampEnd, // clamps the value to the end and extend the start
}

1.0.2+2 #

  • improved documentation
  • fixed type errors

1.0.2+1 #

  • fixed the length error

1.0.2 #

  • fixed Extrapolate.clamp and Extrapolate.clampEnd returning 0.0

1.0.1+2 #

  • added flutter support

1.0.1+1 #

  • fixed bugs

1.0.1+1 #

  • fixed bugs

1.0.0 #

  • Initial release

example/example.dart

import 'package:interpolate/interpolate.dart';

main() {
  Interpolate interpolate = Interpolate(
    inputRange: [10, 20, 30],
    outputRange: [1, 0, 1],
    extrapolate: Extrapolate.clamp,
  );
  interpolate.eval(15); // returns 1.5
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  interpolate: ^1.0.2+2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:interpolate/interpolate.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
52
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
76
Learn more about scoring.

We analyzed this package on Jun 5, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.2
  • pana: 0.13.8-dev
  • Flutter: 1.17.1

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test