indent 1.0.0+2
indent: ^1.0.0+2

Dart native js
Flutter Android iOS web

Change indentation in multiline Dart strings while preserving the existing relative indentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  indent: ^1.0.0+2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:indent/indent.dart';
2
likes
100
pub points
70%
popularity

Publisher

iiro.dev

Change indentation in multiline Dart strings while preserving the existing relative indentation.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

More

Packages that depend on indent