incremental_dom_facade 0.0.3

incremental_dom_facade #

Use Incremental DOM in Dart

Usage #

A simple usage example:

import 'dart:html';
import 'package:incremental_dom_facade/incremental_dom_facade.dart';

main() {
  final d1 = new Data('data 1', true);
  final d2 = new Data('data 2', true);

  final parent = document.getElementById('output');

  patch(parent, (data) {
  }, d1);

  // or
  patch(parent, render, d1);

  // Alternatively
  patch(parent, (_) {

render(Data data) {
  elementVoid('input', '', ['type', 'text']);

  elementOpen('div', '', null);
  if (data.isDone) {

class Data {
  String text = 'default text';
  bool isDone = false;

  Data([this.text, this.isDone]);

Bugs, Fixes, Enhancements #

All feedback, PRs and bug reports are welcome.

Changelog #

0.0.2 #

Expose attributes, applyAttr and applyProp

0.0.1 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  incremental_dom_facade: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:incremental_dom_facade/incremental_dom_facade.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0