inappcalling 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • new21

inappcalling #

A new Flutter plugin that exposes and enables in app voice and video calling logic/features in dart using agora.

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

0.0.1 #

  • TODO: Describe initial release.

example/lib/main.dart

import 'dart:async';

import 'package:flutter/material.dart';
import 'package:flutter/services.dart';
import 'package:inappcalling/inappcalling.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _platformVersion = 'Unknown';

  @override
  void initState() {
    super.initState();
    initPlatformState();
  }

  // Platform messages are asynchronous, so we initialize in an async method.
  Future<void> initPlatformState() async {
    String platformVersion;
    // Platform messages may fail, so we use a try/catch PlatformException.
    try {
      platformVersion = await InAppCalling.platformVersion;
    } on PlatformException {
      platformVersion = 'Failed to get platform version.';
    }

    // If the widget was removed from the tree while the asynchronous platform
    // message was in flight, we want to discard the reply rather than calling
    // setState to update our non-existent appearance.
    if (!mounted) return;

    setState(() {
      _platformVersion = platformVersion;
    });
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: Center(
          child: Text('Running on: $_platformVersion\n'),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  inappcalling: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:inappcalling/inappcalling.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
23
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
21
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Health issues and suggestions

Fix lib/scr/CallScreen.dart. (-68.52 points)

Analysis of lib/scr/CallScreen.dart failed with 4 errors, 1 hint:

line 312 col 9: This requires the 'control-flow-collections' experiment to be enabled.

line 313 col 9: This requires the 'control-flow-collections' experiment to be enabled.

line 553 col 11: This requires the 'control-flow-collections' experiment to be enabled.

line 573 col 11: This requires the 'spread-collections' experiment to be enabled.

line 331 col 5: Dead code.

Fix lib/scr/PickUpScreen.dart. (-25 points)

Analysis of lib/scr/PickUpScreen.dart failed with 1 error:

line 441 col 11: This requires the 'control-flow-collections' experiment to be enabled.

Document public APIs. (-0.63 points)

396 out of 401 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/scr/CallEngine.dart. (-0.50 points)

Analysis of lib/scr/CallEngine.dart reported 1 hint:

line 78 col 16: The value of the local variable 'otherPersonId' isn't used.

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
agora_rtc_engine ^1.0.11 1.0.13 3.0.1-dev.1
animated_widgets ^1.0.6 1.0.6
cached_network_image ^2.0.0 2.2.0+1 2.3.0-rc
cloud_firestore ^0.13.4+2 0.13.7
dio ^3.0.8 3.0.9
dio_http2_adapter ^1.0.0 1.0.0
firebase_auth ^0.16.1 0.16.1
firebase_messaging ^6.0.9 6.0.16
flutter 0.0.0
flutter_call_kit ^0.0.2 0.0.2
flutter_incall ^1.0.0 1.0.0
flutter_voip_push_notification ^0.0.3 0.0.3
http ^0.12.1 0.12.1
path_provider ^1.6.10 1.6.11
permission_handler ^5.0.0+hotfix.9 5.0.1+1
uuid ^2.0.4 2.2.0
video_player ^0.10.5+2 0.10.11+2
Transitive dependencies
charcode 1.1.3
clock 1.0.1
cloud_firestore_platform_interface 1.1.2
cloud_firestore_web 0.1.1+2
collection 1.14.12 1.14.13
convert 2.1.1
crypto 2.1.5
file 5.2.1
firebase 7.3.0
firebase_auth_platform_interface 1.1.8
firebase_auth_web 0.1.3+1
firebase_core 0.4.5
firebase_core_platform_interface 1.0.4
firebase_core_web 0.1.1+2
flutter_cache_manager 1.4.1
flutter_web_plugins 0.0.0
http2 1.0.0
http_parser 3.1.4
intl 0.16.1
js 0.6.2
matcher 0.12.8
meta 1.1.8 1.2.2
path 1.7.0
path_provider_linux 0.0.1+2
path_provider_macos 0.0.4+3
path_provider_platform_interface 1.0.2
pedantic 1.9.0 1.9.2
permission_handler_platform_interface 2.0.1
platform 2.2.1
plugin_platform_interface 1.0.2
process 3.0.13
quiver 2.1.3
rxdart 0.24.1
sky_engine 0.0.99
source_span 1.7.0
sqflite 1.3.1
sqflite_common 1.0.2+1
stack_trace 1.9.5
string_scanner 1.0.5
synchronized 2.2.0+1
term_glyph 1.1.0
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
video_player_platform_interface 2.0.2
video_player_web 0.1.3+2
xdg_directories 0.1.0
Dev dependencies
flutter_test