imsdk 0.0.14

  • Readme
  • Changelog
  • Example
  • Installing
  • 42

imsdk #

Flutter plugin for Tencent IM SDK.

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

0.0.13 #

  • Add - Send image,voice,emoji message support.
  • Add - Get self profile and other users profile support.
  • Add - Modify self profile support.


imsdk_example #

Demonstrates how to use the imsdk plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  imsdk: ^0.0.14

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:imsdk/imsdk.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Dec 9, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Health suggestions

Fix lib/imsdk.dart. (-0.50 points)

Analysis of lib/imsdk.dart reported 1 hint:

line 14 col 35: This function has a return type of 'Future', but doesn't end with a return statement.

Format lib/conversation.dart.

Run flutter format to format lib/conversation.dart.

Format lib/message.dart.

Run flutter format to format lib/message.dart.

Format lib/message_element.dart.

Run flutter format to format lib/message_element.dart.

Format lib/profile.dart.

Run flutter format to format lib/profile.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (json_annotation).

The package description is too short. (-16 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Package is getting outdated. (-5.48 points)

The package was last published 55 weeks ago.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
json_annotation ^0.2.3 0.2.9+1 3.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
build_runner ^0.9.0
json_serializable ^0.5.4