idle_tracker 0.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 42

idle_tracker #

A tiny package that tracks idleness in a web application.

Usage #

A simple usage example:

import 'package:idle_tracker/idle_tracker.dart';

void main() {
  new IdleTracker(
      timeout: const Duration(seconds: 5),
      periodicIdleCall: true,
      startsAsIdle: true,
      onIdle: () => print('Hey, are you there?'),
      onActive: () => print('Welcome back!'))

Features and bugs #

Please file feature requests and bugs at the issue tracker.

Changelog #

0.0.2 #

  • BREAKING CHANGE: This version requires Dart 2.0.0 or later

0.0.1 #

  • Initial version


import 'dart:html';

import 'package:idle_tracker/idle_tracker.dart';

void main() {
      timeout: const Duration(seconds: 5),
      periodicIdleCall: true,
      startsAsIdle: true,
      onIdle: onIdle,
      onActive: onActive)

var count = 0;
final output = document.querySelector('#output');

void log(String message) {
  if (output.children.length >= 40) {
    output.innerHtml = '';
  output.append(DivElement()..text = message);

void onActive() {
  count = 0;
  log('Welcome back!');

void onIdle() {
  if (count++ < 10) log('Hey, are you there?');

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  idle_tracker: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:idle_tracker/idle_tracker.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Apr 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6

Maintenance suggestions

Package is getting outdated. (-57.53 points)

The package was last published 82 weeks ago.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-3 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
Dev dependencies
build_runner ^0.10.0
build_web_compilers ^0.4.0