icons_by_name 0.1.0

  • Readme
  • Changelog
  • Installing
  • 32

icons_by_name #

This package's use case is to provide access to the full library of Icons and FontAwesomeIcons at runtime when the specific icons needed are not known at compile time. As such, all Tree Shaking is totally worked around/defeated for Icons and FontAwesomeIcons, so know that before you use the library.

The methods you may want to consider using include:

getIconUsingPrefix(name: "PREFIX.ICON_NAME") - if PREFIX is "fa" or "fontawesome" the icon_name after the "." will be resolved against the font awesome icons first, if that fails, it'll go to Material Design Icons. If there is no PREFIX.ICON_NAME, it'll fail over to just trying to resolve Material First, then Font Awesome.

getIconGuessFavorFA(name:"ICON_NAME") - if there is an icon named ICON_NAME in FA, return that, otherwise, try Material

getIconGuessFavorMaterial(name:"ICON_NAME") - if there is an icon named ICON_NAME in Material Design, return that, otherwise, try FA

All methods will return null if icon doesn't exist.

I basically wrote this as a hack/work around to https://github.com/flutter/flutter/issues/16189.

Getting Started #

For help getting started with Flutter, view the online documentation.

[0.0.7] - Formatting, et al.

  • Not any functional changes, just friendlier packaging items.

[0.0.1] - Initial release 29 July 2018.

  • Just the basic functions.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  icons_by_name: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:icons_by_name/icons_by_name.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
34
Health:
Code health derived from static analysis. [more]
16
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
32
Learn more about scoring.

We analyzed this package on Oct 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms:

Error(s) prevent platform classification:

Error(s) in lib/icons_by_name.dart: Const variables must be initialized with a constant value.

Health issues and suggestions

Fix lib/icons_by_name.dart. (-57.81 points)

Analysis of lib/icons_by_name.dart failed with 3 errors:

line 840 col 21: Const variables must be initialized with a constant value.

line 840 col 21: The values in a const map literal must be constant.

line 840 col 38: The getter 'nintendoSwitch' isn't defined for the class 'FontAwesomeIcons'.

Document public APIs. (-1 points)

8 out of 8 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Error(s) in lib/icons_by_name.dart: Const variables must be initialized with a constant value.

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/HeyYouNotYouYou/icons_helper was unreachable.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and icons_by_name.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <3.0.0
flutter 0.0.0
flutter_driver 0.0.0
font_awesome_flutter ^8.0.1 8.5.0
Transitive dependencies
async 2.3.0 2.4.0
boolean_selector 1.0.5
charcode 1.1.2
collection 1.14.11 1.14.12
convert 2.1.1
crypto 2.1.1+1 2.1.3
file 5.0.8+1 5.1.0
fuchsia_remote_debug_protocol 0.0.0
intl 0.15.8 0.16.0
json_rpc_2 2.1.0
matcher 0.12.5 0.12.6
meta 1.1.7
path 1.6.4
pedantic 1.8.0+1
platform 2.2.1
process 3.0.11 3.0.12
pub_semver 1.4.2
quiver 2.0.5
sky_engine 0.0.99
source_span 1.5.5
stack_trace 1.9.3
stream_channel 2.0.0
string_scanner 1.0.5
term_glyph 1.1.0
test_api 0.2.5 0.2.9
typed_data 1.1.6
vector_math 2.0.8
vm_service_client 0.2.6+2 0.2.6+3
web_socket_channel 1.0.15 1.1.0
Dev dependencies
flutter_test 0.0.0
test any