http_routes 1.0.0+3

  • Readme
  • Changelog
  • Example
  • Installing
  • new61

http_routes #

Utility to match http requests with routes

GitHub stars Twitter Follow

Usage #

import 'dart:io';

import 'package:http_routes/http_routes.dart';

void main() async {
  final server = await HttpServer.bind(InternetAddress.anyIPv4, 3000);

  await for (HttpRequest req in server) {
    final route = req.route();

    if (route == GET('/todos')) print('get all todos');
    if (route == GET('/todos/:id'))
      print('get todo with id ${route.param('id')}');

    if (route == GET('/lists/:listId/:todoId'))
      print(
          'get todo with id ${route.param('todoId')} from list ${route.param('listId')}');
  }
}

License #

MIT

GitHub stars Twitter Follow

[1.0.0+3] - 2019-12-24

  • implement fromString

[1.0.0+2] - 2019-12-24

  • implement toString

[1.0.0] - 2019-12-24

  • initial release

example/lib/main.dart

import 'dart:io';

import 'package:http_routes/http_routes.dart';

void main() async {
  final server = await HttpServer.bind(InternetAddress.anyIPv4, 3000);

  await for (HttpRequest req in server) {
    final route = req.route();

    if (route == GET('/todos')) print('get all todos');
    if (route == GET('/todos/:id'))
      print('get todo with id ${route.param('id')}');

    if (route == GET('/lists/:listId/:todoId'))
      print(
          'get todo with id ${route.param('todoId')} from list ${route.param('listId')}');
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  http_routes: ^1.0.0+3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:http_routes/http_routes.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
28
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
86
Overall:
Weighted score of the above. [more]
61
Learn more about scoring.

We analyzed this package on Jan 19, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health issues and suggestions

Document public APIs. (-0.17 points)

34 out of 35 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/http_routes.dart. (-0.50 points)

Analysis of lib/http_routes.dart reported 1 hint:

line 38 col 10: Test type arguments in operator ==(Object other).

Maintenance suggestions

The package description is too short. (-14 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test