http_logger 1.0.0

  • Readme
  • Changelog
  • Installing
  • 71

http_logger #

A logging middleware for Dart's http module.

Usage #

http_logger uses the http_middleware package to implement logging.

Add the http_middleware and http_logger in your project.

http_middleware: any
http_logger: any

The setup is simple. You need to create an object of HttpWithMiddleware or HttpClientWithMiddleware and add the HttpLogger middleware in it.

HttpWithMiddleware httpClient = HttpWithMiddleware.build(middlewares: [
  HttpLogger(logLevel: LogLevel.BODY),
]);

var response = await httpClient.post(
  'https://jsonplaceholder.typicode.com/posts/',
  body: jsonEncode({"test1": "THis is a test"}),
  headers: {"Content-Type": "application/json"});

There are different log levels that you can use.

LogLevel.BODY
LogLevel.HEADER
LogLevel.BASIC
LogLevel.NONE

[0.0.1] - TODO: Add release date. #

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  http_logger: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:http_logger/http_logger.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
83
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
71
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.9+1

Analysis suggestions

Package not compatible with SDK dart

because of import path [http_logger]

Package not compatible with runtime flutter-web of web

Because of the import of dart:io via the import chain package:http_logger/http_logger.dart->package:http_logger/logging_middleware.dart->package:http_middleware/http_middleware.dart->package:http_middleware/http_with_middleware.dart->package:http_middleware/middleware_contract.dart->package:http_middleware/models/response_data.dart->package:http/http.dart->package:http/src/streamed_response.dart->package:http/src/base_request.dart->package:http/src/client.dart->package:http/src/io_client.dart->dart:io

Health suggestions

Fix lib/logger.dart. (-1.99 points)

Analysis of lib/logger.dart reported 4 hints:

line 24 col 18: Avoid using braces in interpolation when not needed.

line 25 col 18: Avoid using braces in interpolation when not needed.

line 57 col 20: Avoid using braces in interpolation when not needed.

line 72 col 16: Avoid using braces in interpolation when not needed.

Maintenance suggestions

Package is getting outdated. (-84.38 points)

The package was last published 96 weeks ago.

The package description is too short. (-16 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and http_logger.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Homepage URL is insecure. (-5 points)

Update the homepage field and use a secure (https) URL.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
http_middleware ^1.0.0 1.0.0
Transitive dependencies
async 2.4.1
charcode 1.1.3
collection 1.14.13
http 0.11.3+17 0.12.1
http_parser 3.1.4
meta 1.1.8 1.2.0
path 1.7.0
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.2.0