http2_bridge 1.0.0-alpha

http2_bridge #

Pub

Handle HTTP/2 requests as if they were dart:io HttpRequests.

This package is currently in alpha, mainly because I have no practical idea of how to test it. Stay tuned.

Usage #

Use the adaptHttp2Stream function to bridge HTTP/2 requests to an existing HTTP/1.1 handler.

import 'dart:io';
import 'package:http2/multiprotocol_server.dart';
import 'package:http2_bridge/http2_bridge.dart';

main() async {
  var ctx = new SecurityContext();
  ctx.useCertificateChainFile('keys/server_chain.pem');
  ctx.usePrivateKeyFile('keys/server_key.pem');
  var server = await MultiProtocolServer.bind('127.0.0.1', 443, ctx);
  
  server.startServing(
    // Serve HTTP/1.1 as normal
    handleRequest,
    
    // Handle HTTP/2 streams as though they were HTTP/1.1 requests...
    adaptHttp2Stream(handleRequest)
  );
}

handleRequest(HttpRequest request) async {
  // Do something...
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  http2_bridge: ^1.0.0-alpha

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:http2_bridge/http2_bridge.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0