horizontal_picker 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • new70

Horizontal Picker #

You can select your value on Horizontal Picker while scrolling on items.

Samples #

Horizontal Picker - Sample 1

Horizontal Picker - Sample 2

Horizontal Picker - Sample 3

Installation #

Installing section

Usage Example #

HorizantalPicker(
  minValue: -10,
  maxValue: 50,
  divisions: 600,
  suffix: " cm",
  showCursor: false,
  backgroundColor: Colors.grey.shade900,
  activeItemTextColor: Colors.white,
  passiveItemsTextColor: Colors.amber,
  onChanged: (value) {},
),

[1.0.0]

  • Upgraded to stable

[0.0.5]

  • Updated read.me

[0.0.4]

  • Fixed decimal count bug

[0.0.3]

  • Updated read.me

[0.0.2]

  • Initial release

example/README.md

Example #

An example Flutter project with horizontal_picker package.

Getting Started #

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  horizontal_picker: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:horizontal_picker/horizontal_picker.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
41
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
70
Learn more about scoring.

We analyzed this package on Jan 19, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test