hometec_ui 1.1.26

  • Readme
  • Changelog
  • Installing
  • 6

hometec_ui #

A new Flutter package project.

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

[0.0.1] - TODO: Add release date. #

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  hometec_ui: ^1.1.26

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:hometec_ui/hometec_ui.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
30
Overall:
Weighted score of the above. [more]
6
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15
  • Flutter: 1.17.5

Health issues and suggestions

Fix lib/components/button/size.dart. (-92.64 points)

Analysis of lib/components/button/size.dart failed with 9 errors, 4 hints, including:

line 8 col 1: Undefined class 'extension'.

line 8 col 1: This requires the 'extension-methods' experiment to be enabled.

line 8 col 31: Undefined class 'on'.

line 8 col 34: The name 'ButtonSize' is already defined.

line 8 col 34: Functions must have an explicit list of parameters.

Fix lib/components/button/type.dart. (-92.60 points)

Analysis of lib/components/button/type.dart failed with 9 errors, 3 hints, including:

line 22 col 1: Undefined class 'extension'.

line 22 col 1: This requires the 'extension-methods' experiment to be enabled.

line 22 col 31: Undefined class 'on'.

line 22 col 34: The name 'ButtonType' is already defined.

line 22 col 34: Functions must have an explicit list of parameters.

Fix lib/components/button/button.dart. (-92.53 points)

Analysis of lib/components/button/button.dart failed with 9 errors, 1 hint, including:

line 10 col 3: ButtonType isn't a type.

line 11 col 3: ButtonSize isn't a type.

line 16 col 27: ButtonType isn't a type.

line 16 col 45: The default value of an optional parameter must be constant.

line 16 col 56: The getter 'solid' isn't defined for the type 'dynamic Function()'.

Fix additional 34 files with analysis or formatting issues. (-710.67 points)

Additional issues in the following files:

  • lib/resources/fonts/font.dart (7 errors, 4 hints)
  • lib/components/dialog/alert_dialog.dart (7 errors)
  • lib/components/textfield/textfield.dart (4 errors)
  • lib/components/dialog/console_dialog.dart (3 errors)
  • lib/components/label/label_text.dart (3 errors)
  • lib/components/state_list/state_list.dart (3 errors)
  • lib/components/state_list/state_list_future.dart (3 errors)
  • lib/components/dialog/loading_dialog.dart (2 errors)
  • lib/components/section/section2.dart (2 errors)
  • lib/components/appbar_title/appbar_title.dart (1 error)
  • lib/components/button/button_app_bar.dart (1 error)
  • lib/components/collectiion/collection.dart (1 error)
  • lib/components/collectiion/collection_item.dart (1 error)
  • lib/components/image_button/image_button.dart (1 error)
  • lib/components/section/section.dart (1 error)
  • lib/components/app_bar/app_bar.dart (Run flutter format to format lib/components/app_bar/app_bar.dart.)
  • lib/components/button/button_bottom_sheet.dart (Run flutter format to format lib/components/button/button_bottom_sheet.dart.)
  • lib/components/dialog/cupertino_dialog.dart (Run flutter format to format lib/components/dialog/cupertino_dialog.dart.)
  • lib/components/dialog/dialog.dart (Run flutter format to format lib/components/dialog/dialog.dart.)
  • lib/components/form/card_info.dart (Run flutter format to format lib/components/form/card_info.dart.)
  • lib/components/page_transition/slider_transition.dart (Run flutter format to format lib/components/page_transition/slider_transition.dart.)
  • lib/components/progress_bar/loading_progress_bar.dart (Run flutter format to format lib/components/progress_bar/loading_progress_bar.dart.)
  • lib/components/state_list/model/state_list_model.dart (Run flutter format to format lib/components/state_list/model/state_list_model.dart.)
  • lib/components/textfield/controller/abstract_textfield_controller.dart (Run flutter format to format lib/components/textfield/controller/abstract_textfield_controller.dart.)
  • lib/components/textfield/controller/greater_than_zero_textfield_controller.dart (Run flutter format to format lib/components/textfield/controller/greater_than_zero_textfield_controller.dart.)
  • lib/components/textfield/controller/required_textfield_controller.dart (Run flutter format to format lib/components/textfield/controller/required_textfield_controller.dart.)
  • lib/components/textfield/controller/textfield_controller.dart (Run flutter format to format lib/components/textfield/controller/textfield_controller.dart.)
  • lib/components/textfield/textfield_value.dart (Run flutter format to format lib/components/textfield/textfield_value.dart.)
  • lib/components/textfield/validator.dart (Run flutter format to format lib/components/textfield/validator.dart.)
  • lib/formatters/number_formatter.dart (Run flutter format to format lib/formatters/number_formatter.dart.)
  • lib/formatters/peso_formatter.dart (Run flutter format to format lib/formatters/peso_formatter.dart.)
  • lib/measure_size.dart (Run flutter format to format lib/measure_size.dart.)
  • lib/resources/colors/color.dart (Run flutter format to format lib/resources/colors/color.dart.)
  • lib/resources/enums/image_enum.dart (Run flutter format to format lib/resources/enums/image_enum.dart.)

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

exitCode: 255 stdout: Documenting hometec_ui... Initialized dartdoc with 613 libraries in 96.6 seconds Generating docs for library abstract_textfield_controller from package:hometec_ui/components/textfield/controller/abstract_textfield_controller.dart... Generating docs for library alert_dialog from package:hometec_ui/components/dialog/alert_dialog.dart... Generating docs for library app_bar from package:hometec_ui/components/app_bar/app_bar.dart... Generating docs for library appbar_title from package:hometec_ui/components/appbar_title/appbar_title.dart... Generating docs for library button_app_bar from package:hometec_ui/components/button/button_app_bar.dart... Generating docs for library button_bottom_sheet from package:hometec_ui/components/button/button_bottom_sheet.dart... Generating docs for library card_info from package:hometec_ui/components/form/card_info.dart... Generating docs for library collection from package:hometec_ui/components/collectiion/collection.dart... Generating docs for library collection_item from package:hometec_ui/components/collectiion/collection_item.dart... Generating docs for library color from package:hometec_ui/resources/colors/color.dart... Generating docs for library console_dialog from package:hometec_ui/components/dialog/console_dialog.dart... Generating docs for library cupertino_dialog from package:hometec_ui/components/dialog/cupertino_dialog.dart... Generating docs for library dialog from package:hometec_ui/components/dialog/dialog.dart... Generating docs for library font from package:hometec_ui/resources/fonts/font.dart... Generating docs for library greater_than_zero_textfield_controller from package:hometec_ui/components/textfield/controller/greater_than_zero_textfield_controller.dart... Generating docs for library hometec_ui from package:hometec_ui/components/button/button.dart... Generating docs for library hometec_ui from package:hometec_ui/hometec_ui.dart... Generating docs for library image_button from package:hometec_ui/components/image_button/image_button.dart... Generating docs for library image_enum from package:hometec_ui/resources/enums/image_enum.dart... Generating docs for library label_text from package:hometec_ui/components/label/label_text.dart... Generating docs for library loading_dialog from package:hometec_ui/components/dialog/loading_dialog.dart... Generating docs for library loading_progress_bar from package:hometec_ui/components/progress_bar/loading_progress_bar.dart... Generating docs for library measure_size from package:hometec_ui/measure_size.dart... Generating docs for library number_formatter from package:hometec_ui/formatters/number_formatter.dart... Generating docs for library peso_formatter from package:hometec_ui/formatters/peso_formatter.dart... Generating docs for library required_textfield_controller from package:hometec_ui/components/textfield/controller/required_textfield_controller.dart... Generating docs for library section from package:hometec_ui/components/section/section.dart... Generating docs for library section2 from package:hometec_ui/components/section/section2.dart... Generating docs for library size from package:hometec_ui/components/button/size.dart... Generating docs for library slider_transition from package:hometec_ui/components/page_transition/slider_transition.dart... Generating docs for library state_list from package:hometec_ui/components/state_list/state_list.dart... Generating docs for library state_list_future from package:hometec_ui/components/state_list/state_list_future.dart... Generating docs for library state_list_model from package:hometec_ui/components/state_list/model/state_list_model.dart... Generating docs for library textfield from package:hometec_ui/components/textfield/textfield.dart... Generating docs for library textfield_controller from package:hometec_ui/components/textfield/controller/textfield_controller.dart... Generating docs for library textfield_value from package:hometec_ui/components/textfield/textfield_value.dart... Generating docs for library type from package:hometec_ui/components/button/type.dart... Generating docs for library validator from package:hometec_ui/components/textfield/validator.dart... Validating docs... Documented 38 public libraries in 21.5 seconds stderr: warning: hometec_ui has no library level documentation comments, from hometec_ui: (file:///tmp/pub-dartlang-dartdocKMQIEN/pkg/lib/components/button/button.dart:1:9) warning: hometec_ui has no library level documentation comments, from hometec_ui: (file:///tmp/pub-dartlang-dartdocKMQIEN/pkg/lib/hometec_ui.dart:1:9) error: failed to write file at: hometec_ui/hometec_ui-library.html for symbol hometec_ui: (file:///tmp/pub-dartlang-dartdocKMQIEN/pkg/lib/hometec_ui.dart:1:9) conflicting with file already generated by hometec_ui: (file:///tmp/pub-dartlang-dartdocKMQIEN/pkg/lib/components/button/button.dart:1:9) Dartdoc generates a path and filename to write to for each symbol. hometec_ui conflicts with another symbol in the generated path, and therefore can not be written out. Changing the name, library name, or class name (if appropriate) of one of the conflicting items can resolve the conflict. Alternatively, use the @nodoc tag in one symbol's documentation comments to hide it. warning: unresolved doc reference [EditableText] from number_formatter.NumberFormatter.formatEditUpdate: (file:///tmp/pub-dartlang-dartdocKMQIEN/pkg/lib/formatters/number_formatter.dart:5:20) in documentation inherited from text_formatter.TextInputFormatter.formatEditUpdate: (file:///flutter/packages/flutter/lib/src/services/text_formatter.dart:41:20) warning: unresolved doc reference [EditableText] from peso_formatter.PesoFormatter.formatEditUpdate: (file:///tmp/pub-dartlang-dartdocKMQIEN/pkg/lib/formatters/peso_formatter.dart:5:20) in documentation inherited from text_formatter.TextInputFormatter.formatEditUpdate: (file:///flutter/packages/flutter/lib/src/services/text_formatter.dart:41:20) warning: dartdoc generated a broken link to: hometec_ui/ECButton-class.html (from index.json) warning: dartdoc generated a broken link to: hometec_ui/ECButton/ECButton.html (from index.json) warning: dartdoc generated a broken link to: hometec_ui/ECButton/backgroundColor.html (from index.json) warning: dartdoc generated a broken link to: hometec_ui/ECButton/createState.html (from index.json) warning: dartdoc generated a broken link to: hometec_ui/ECButton/onPressed.html (from index.json) warning: dartdoc generated a broken link to: hometec_ui/ECButton/size.html (from index.json) warning: dartdoc generated a broken link to: hometec_ui/ECButton/textColor.html (from index.json) warning: dartdoc generated a broken link to: hometec_ui/ECButton/title.html (from index.json) warning: dartdoc generated a broken link to: hometec_ui/ECButton/type.html (from index.json) found 13 warnings and 1 error Unhandled exception: dartdoc encountered 1 errors while processing. #0 Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:225:9)

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (rxdart).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and hometec_ui.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
progress_dialog ^1.2.0 1.2.4
rxdart ^0.23.1 0.23.1 0.24.1
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test