hl_des 2.0.2 icon indicating copy to clipboard operation
hl_des: ^2.0.2 copied to clipboard

A new flutter plugin project.

hl_des #

Flutter DES encryption and decryption.

Supported: DES/CBC/PKCS7Padding

Getting Started #

Add dependency #

dependencies:
  hl_des: ^2.0.2  #latest version

Example #

import 'package:hl_des/hl_des.dart';

void example() async {
  const string = "Java, android, ios, get the same result by DES encryption and decryption."; // base64
  const key = "xxx="; // base64
  const iv = "xxx="; // base64

  decrypted = await HlDes.desDecrypt(data: string, iv: iv, key: key);
  print("decrypted = $decrypted");

  final encrypted = await HlDes.desEncrypt(data: decrypted, iv: iv, key: key);
  print("encrypted = $encrypted");
}
0
likes
90
pub points
1%
popularity

Publisher

unverified uploader

A new flutter plugin project.

Homepage

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on hl_des