hive_touch_id 1.0.1

  • Readme
  • Changelog
  • Installing
  • 52

Flutter Desktop TouchID #

TouchID implementation for flutter desktop on macos

Getting Started #

The package requares macos 10.12.2 or newer.

import the package

import 'package:hive_touch_id/hive_touch_id.dart';

Perform touch ID authentification with provided prompt text

void touchID() async{
  TouchIDData value = await HiveTouchId.Auth("auth");
  if (value.success){
  } else if (value.touchIDConfigured){
    print("Canceled or Error");
  } else {
    print("Touch Id is not avalible or not configured on the device");

1.0.1 #

Change auth method to deviceOwnerAuthentication

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  hive_touch_id: ^1.0.1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:hive_touch_id/hive_touch_id.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Mar 31, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Health suggestions

Fix lib/hive_touch_id.dart. (-0.50 points)

Analysis of lib/hive_touch_id.dart reported 1 hint:

line 18 col 30: Name non-constant identifiers using lowerCamelCase.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and hive_touch_id.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.

The package description is too short. (-8 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies