hbase 0.0.4

  • Readme
  • Changelog
  • Installing
  • 2

hbase #

A new Flutter package.

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

[0.0.1] - TODO: Add release date. #

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  hbase: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:hbase/hbase.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Apr 4, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Health issues and suggestions

Fix lib/base/interface/i_presenter.dart. (-43.75 points)

Analysis of lib/base/interface/i_presenter.dart failed with 2 errors:

line 5 col 37: Type parameter bound types must be instantiated.

line 5 col 54: Type parameter bound types must be instantiated.

Fix lib/base/presenter.dart. (-43.75 points)

Analysis of lib/base/presenter.dart failed with 2 errors:

line 6 col 36: Type parameter bound types must be instantiated.

line 6 col 53: Type parameter bound types must be instantiated.

Fix lib/base/interactor.dart. (-25 points)

Analysis of lib/base/interactor.dart failed with 1 error:

line 5 col 37: Type parameter bound types must be instantiated.

Fix additional 4 files with analysis or formatting issues. (-100 points)

Additional issues in the following files:

  • lib/base/interface/i_interactor.dart (1 error)
  • lib/base/interface/i_view.dart (1 error)
  • lib/base/interface/presenter_view.dart (1 error)
  • lib/base/view_fragment.dart (1 error)

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://www.nguyenvanhien.net was unreachable.

Package is getting outdated. (-60.55 points)

The package was last published 83 weeks ago.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and hbase.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0<3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies