h264 0.1.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 70

h264 #

A simple Flutter plugin which decodes raw h264 IDR frames into bitmap representations.

The plugin utilizes platform code and does not depend on 3rd party libraries.

Open issues #

  • [ ] iOS Support
  • [ ] Customize output format
  • [ ] Import a lot more sample files for validation (generate them through ffmpeg perhaps)
  • [ ] Reduce Android API level requirements to 16+ (currently 21+ due to modern API usage)

0.1.0 #

  • Android: Checked the decoding compatibility with 10 different phones starting on Android 5.1+

0.0.4 #

  • Android: Ensure to return results on the main thread.
  • Android: Upgrade gradle infrastructure.

0.0.3 #

  • iOS Support

0.0.2 #

  • Migrated to AndroidX

0.0.1 #

  • Initial Release with Android support

example/README.md

h264_example #

Demonstrates how to use the h264 plugin.

Getting Started #

This project ships with a few H264 sample files, which will be handed to the platform for decoding.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  h264: ^0.1.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:h264/h264.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
47
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
86
Overall:
Weighted score of the above. [more]
70
Learn more about scoring.

We analyzed this package on Oct 18, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The package description is too short. (-14 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8