grove 1.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 56

grove #

Build Status

This package provides interface classes to the Grove series of devices comprising of sensors, actuators, display devices, communications and others. The package provides initialisation functionality and the ability to read sensor values both raw and conditioned, e.g. the light sensor supplies both raw values read from the device and a corresponding Lux value.

Grove builds on the mraa package to perform low level device communication and presents a logical device function oriented interface to the user.

Examples of usage for each of the supported devices can be found in the examples directory.

This package is intended to grow over time as devices are added, if any specific devices need to be supported please raise an issue and these will be considered in priority.

1.0.2 #

Linter + pana updates

1.0.1 #

Linter updates

1.0.0 #

Initial release

example/grove.dart

/*
 * Package : grove
 * Author : S. Hamblett <steve.hamblett@linux.com>
 * Date   : 10/11/2019
 * Copyright :  S.Hamblett
 */

///
/// Please see the examples in this directory
///

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  grove: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:grove/grove.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
12
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
56
Learn more about scoring.

We analyzed this package on Jul 7, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Analysis suggestions

Package not compatible with runtime flutter-web on web

Because of the import of dart:io via the import chain package:grove/grove.dartpackage:mraa/mraa.dartpackage:ffi/ffi.dartpackage:ffi/src/allocation.dartdart:io

Package not compatible with runtime web

Because of the import of dart:io via the import chain package:grove/grove.dartpackage:mraa/mraa.dartpackage:ffi/ffi.dartpackage:ffi/src/allocation.dartdart:io

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.6.0 <3.0.0
ffi ^0.1.3 0.1.3
mraa ^1.1.2 1.1.2
Dev dependencies
mockito ^4.1.1
pana ^0.13.5
pedantic ^1.9.0
test ^1.14.2