grock_dart 0.1.1 copy "grock_dart: ^0.1.1" to clipboard
grock_dart: ^0.1.1 copied to clipboard

Dart language version of the Grock package.

This is Grock #

alt text

Dart language version of the Grock package.💯💯💯💯💯💯💯💯💯💯💯💯💯💯💯 Flutter Version Link: https://pub.dev/packages/grock

Firstly 🤫 #

  dart pub add grock_dart

Extensions 🤫 #

List Extension #

['data','data1'].mapIndexed((value, index){})
['data','data1'].forLoop((value, index){})
['data','data1'].mapIndexedWhere((value, index))
['data','data1'].mapFiltered((value){})

String Extension #

String.capitalize
String.capitalizeEach
String.capitalizeEachFirst
String.capitalizeEachFirstLower
String.capitalizeEachLower
String.capitalizeEachLowerFirst
String.toDate
String.filter
String.filterNumber
String.forEach
String.forEachFirst
String.forEachFirstLower
String.isPhoneNumber
String.isPhoneNumberWithCountryCode
String.isPhoneNumberWithCountryCodeAndSpace
String.isTurkeyPhoneNumber
String.isTurkeyPhoneNumberWithCountryCode
String.isTurkeyPhoneNumberWithCountryCodeAndSpace
String.isEmail
String.isUrl
String.isUrlWithSpace
String.isEmpty
String.dateTime
String.isDateTimeFormat
String.isSearch("istanbul")

Developer Extension #

'test data'.logger,
'test data'.printer,
2
likes
100
pub points
0%
popularity

Publisher

unverified uploader

Dart language version of the Grock package.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

More

Packages that depend on grock_dart