grizzly_scales 0.0.6

vizzie #

Provides scales and interpolators for grizzly_viz

TODO #

Scales #

  • [ ] Log scale
  • [ ] Color
  • [ ] nice

Interpolators #

  • [ ] Color

General #

  • [ ] Ticks

Examples #

  • Visualize

Changelog #

0.0.6 #

  • Moved Ranger to grizzly_primitives

0.0.5 #

  • Dart2 fixes

0.0.3 #

  • Ranger.range supports double

0.0.2 #

  • Ticks
  • TimeScale
  • TimeRange

0.0.1 #

  • Initial version, created by Stagehand

example/example.dart

// Copyright (c) 2017, teja. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

import 'package:grizzly_scales/grizzly_scales.dart';

main() {
  print(binaryRangeSearch([10, 20, 30, 40, 50, 60], 90));
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  grizzly_scales: ^0.0.6

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:grizzly_scales/grizzly_scales.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0