graphened 0.0.1

  • Readme
  • Changelog
  • Installing
  • 5

graphened #

A Dart library for Graphene/Bitshares blockchain.

Build Status

Getting started #

You should ensure that you add the router as a dependency in your flutter project.

dependencies:
 graphened: ^0.0.1

You can also reference the git repo directly if you want:

dependencies:
 graphened:
   git: git://github.com/pkozlovskiy/graphened.git

[0.0.1] -

  • First reviewed release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  graphened: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:graphened/graphened.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
24
Overall:
Weighted score of the above. [more]
5
Learn more about scoring.

We analyzed this package on Nov 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21

Platforms

Detected platforms:

Low code quality prevents platform classification.

Health issues and suggestions

Fix lib/src/account_options.dart. (-57.81 points)

Analysis of lib/src/account_options.dart failed with 3 errors:

line 7 col 6: Target of URI hasn't been generated: 'account_options.g.dart'.

line 36 col 7: The method '_$AccountOptionsFromJson' isn't defined for the class 'AccountOptions'.

line 38 col 36: The method '_$AccountOptionsToJson' isn't defined for the class 'AccountOptions'.

Fix lib/src/asset.dart. (-57.81 points)

Analysis of lib/src/asset.dart failed with 3 errors:

line 5 col 6: Target of URI hasn't been generated: 'asset.g.dart'.

line 20 col 56: The method '_$AssetFromJson' isn't defined for the class 'Asset'.

line 21 col 36: The method '_$AssetToJson' isn't defined for the class 'Asset'.

Fix lib/src/asset_options.dart. (-57.81 points)

Analysis of lib/src/asset_options.dart failed with 3 errors:

line 2 col 6: Target of URI hasn't been generated: 'asset_options.g.dart'.

line 7 col 63: The method '_$AssetOptionsFromJson' isn't defined for the class 'AssetOptions'.

line 8 col 36: The method '_$AssetOptionsToJson' isn't defined for the class 'AssetOptions'.

Fix additional 6 files with analysis or formatting issues. (-289.05 points)

Additional issues in the following files:

  • lib/src/authority.dart (3 errors)
  • lib/src/extensions.dart (3 errors)
  • lib/src/public_key.dart (3 errors)
  • lib/src/user_account.dart (3 errors)
  • lib/src/votes.dart (3 errors)
  • lib/graphened.dart (Run dartfmt to format lib/graphened.dart.)

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Low code quality prevents platform classification.

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field http://github.com/dart-lang/graphened was unreachable.

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (json_annotation).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and graphened.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-6 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
json_annotation ^2.2.0 2.4.0 3.0.0
Dev dependencies
build_runner ^1.1.3
json_serializable ^2.2.1
test ^1.6.0