grakn 2.0.1

grakn-dart #

A Grakn REST API connector for the Grakn hyper-relational graph database.

Tested with Grakn 1.0 and 1.1

Usage #

A simple usage example:

import "dart:convert";
import 'package:grakn/grakn.dart';

main() async {
    Grakn grakn = new Grakn();
    String rawString = await grakn.execute("match \$x isa thing; get;");
    List rawList = JSON.decode(rawString);
    print('awesome: $rawList');
}

Features and bugs #

Please file feature requests and bugs at the issue tracker.

Changelog #

2.0.1 #

  • documentation

2.0 #

  • Fixes an encoding issue

1.1 #

  • Fixes an issue when the result of the server is bigger than 32k.

1.0 #

  • Initial release. Tested with Grakn 1.0

example/grakn_example.dart

import "dart:convert";
import 'package:grakn/grakn.dart';

main() async {
  Grakn grakn = new Grakn();
  String query = "match \$x isa thing; get;";
  String rawString = await grakn.execute(query);
  List rawList = JSON.decode(rawString);
  print('awesome: $rawList');
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  grakn: ^2.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:grakn/grakn.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0

Admin