gradient_progress 0.1.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 74

gradient_progress #

A Gradient color support progressbar.

Screenshots #

screenshot

Getting Started #

  1. Depend on it by adding this to your pubspec.yaml file: gradient_progress: ^0.0.1

  2. Import it: import 'package:gradient_progress.dart'

  3. Add GradientCircularProgressIndicator in your widget layout and have a gradient progress!

[0.0.1] - TODO: Add release date. #

  • TODO: Describe initial release.

example/lib/example.dart

import 'package:flutter/material.dart';
import 'package:gradient_progress/gradient_progress.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  // This widget is the root of your application.
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Flutter Demo',
      theme: ThemeData(
        primarySwatch: Colors.blue,
      ),
      home: ExampleHomePage(),
    );
  }
}

class ExampleHomePage extends StatefulWidget {
  @override
  _ExampleHomePageState createState() => _ExampleHomePageState();
}

class _ExampleHomePageState extends State<ExampleHomePage> with TickerProviderStateMixin{

  AnimationController _animationController;

  @override
  void initState() {
    _animationController =
    new AnimationController(vsync: this, duration: Duration(seconds: 3));
    _animationController.addListener(() => setState(() {}));
    _animationController.repeat();
    super.initState();
  }

  @override
  Widget build(BuildContext context) {
    return new Scaffold(
        body: new Center(
          child: GradientCircularProgressIndicator(
            gradientColors: [Colors.yellow, Colors.red],
            radius: 40,
            strokeWidth: 8.0,
            value: new Tween(begin: 0.0, end: 1.0)
                .animate(CurvedAnimation(
                parent: _animationController, curve: Curves.decelerate))
                .value,
          ),
        ),
      );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  gradient_progress: ^0.1.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:gradient_progress/gradient_progress.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
53
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
88
Overall:
Weighted score of the above. [more]
74
Learn more about scoring.

We analyzed this package on Apr 4, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Maintenance suggestions

Package is getting outdated. (-12.05 points)

The package was last published 58 weeks ago.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test