gpt_3_dart 0.0.1
gpt_3_dart: ^0.0.1 copied to clipboard

Flutter Android iOS

Unofficial Dart package for OpenAI's GPT-3 API.

gpt_3_dart #

A simple Dart package to use with OpenAI's GPT-3 API.

Installation #

dependencies:
  flutter:
    sdk: flutter
  gpt_3_dart:

Usage #

import 'package:gpt_3_dart/gpt_3_dart.dart';

void main() async {
  OpenAI openAI = new OpenAI(apiKey: "YOUR_KEY_HERE");
  String complete = await openAI.complete("This is a test.", 10);
  List search = await openAI
      .search(["White House", "hospital", "school"], "the president");
  print(complete);
  print(search);
}

Example App #

Text CompletionSemantic Search
2
likes
70
pub points
27%
popularity

Unofficial Dart package for OpenAI's GPT-3 API.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

baroniadhruv9@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, http, meta

More

Packages that depend on gpt_3_dart