google_tag_manager 0.0.3

google_tag_manager #

Dart wrapper around google tag manager js api

Usage #

Install Google Tag Manager (docs)

import 'package:google_tag_manager/google_tag_manager.dart' as gtm;

main() {
  gtm.pushEvent('button1-click');
  gtm.pushEvent('button2-click', data: {'value': 1});
  gtm.push({'variable_name': 'variable_value'});
}

Features and bugs #

Please file feature requests and bugs at the issue tracker.

Changelog #

0.0.2 #

  • fix README

0.0.1 #

  • Initial version, created by Stagehand

example/google_tag_manager_example.dart

import 'package:google_tag_manager/google_tag_manager.dart' as gtm;

main() {
  gtm.pushEvent('button1-click');
  gtm.pushEvent('button2-click', data: {'value': 1});
  gtm.push({'variable_name': 'variable_value'});
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  google_tag_manager: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:google_tag_manager/google_tag_manager.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
41
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
63
Overall:
Weighted score of the above. [more]
63
Learn more about scoring.

We analyzed this package on Sep 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21

Platforms

Detected platforms: web, other

Primary library: package:google_tag_manager/google_tag_manager.dart with components: js.

Health issues and suggestions

Document public APIs. (-1 points)

3 out of 3 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance suggestions

The package description is too short. (-15 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is getting outdated. (-12.05 points)

The package was last published 58 weeks ago.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
js ^0.6.1 0.6.1+1
Dev dependencies
test ^1.3.0