google_plus_v1moments_api 0.1.0

google_plus_v1moments_api #

Description #

Auto-generated client library for accessing the plus v1moments API.

Logo Google+ API - plus v1moments

The Google+ API enables developers to build on top of the Google+ platform.

Official API documentation: https://developers.google.com/+/history/

For web applications:

import "package:google_plus_v1moments_api/plus_v1moments_api_browser.dart" as plusclient;

For console application:

import "package:google_plus_v1moments_api/plus_v1moments_api_console.dart" as plusclient;
var plus = new plusclient.Plus();

Licenses #

Copyright (c) 2013 Gerwin Sturm & Adam Singer

Licensed under the Apache License, Version 2.0 (the "License"); you may not
use this file except in compliance with the License. You may obtain a copy of
the License at

http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
License for the specific language governing permissions and limitations under
the License

------------------------
Based on http://code.google.com/p/google-api-dart-client

Copyright 2012 Google Inc.
Licensed under the Apache License, Version 2.0 (the "License"); you may not
use this file except in compliance with the License. You may obtain a copy of
the License at

http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
License for the specific language governing permissions and limitations under
the License

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  google_plus_v1moments_api: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:google_plus_v1moments_api/plus_v1moments_api_browser.dart';
import 'package:google_plus_v1moments_api/plus_v1moments_api_client.dart';
import 'package:google_plus_v1moments_api/plus_v1moments_api_console.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Admin