google_map_polyline 0.2.0+1

  • Readme
  • Changelog
  • Example
  • Installing
  • 93

Gives polyline coordinates to set polylines in Google Map.

pub package

google_map_polyline #

Flutter plugin to retrieve coordinates (in latitude and longitude) to draw the polylines (Route) in google_maps_flutter package. This package made with the inspiration of flutter_polyline_points.

Getting Started #

To use this plugin, add google_map_polyline as a dependency in your pubspec.yaml file.

Example #

  1. First you need to create object using your Google Maps API key.
  1. Now you may able retrieve coordinates for the Polyline route.
  • Get the Polyline coordinates using location coordinates (latitude and longitude)
          await googleMapPolyline.getCoordinatesWithLocation(
              origin: LatLng(40.677939, -73.941755),
              destination: LatLng(40.698432, -73.924038),
              mode:  RouteMode.driving);	
    
  • Get the Polyline coordinates using address of the location
          await googleMapPolyline.getPolylineCoordinatesWithAddress(
              origin:  '55 Kingston Ave, Brooklyn, NY 11213, USA',
              destination:  '8007 Cypress Ave, Glendale, NY 11385, USA',
              mode:  RouteMode.driving);
    

Overview #

  • [x] Coordinates with Location Coordinates (Latitude and Longitude)
  • [x] Coordinates with Location Address
  • [x] Route Modes
    • [x] Driving
    • [x] Walking
    • [x] Bicycling
  • [ ] Coordinates with Location Coordinates and Address (example: Origin as address and Destination as coordinates)
  • [ ] Alternative routes

Feature Requests and Issues #

Please file feature requests and bugs at the issue tracker.

[0.0.1 - 0.0.3+1]

  • Initial publish

[0.0.4]

  • Updated dependencies

[0.2.0 - 0.2.0+1]

  • Minor changes

example/README.md

google_map_polyline_example #

Demonstrates how to use the google_map_polyline plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  google_map_polyline: ^0.2.0+1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:google_map_polyline/google_map_polyline.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
86
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
93
Learn more about scoring.

We analyzed this package on Dec 7, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
dio ^3.0.2 3.0.7
flutter 0.0.0
google_maps_flutter ^0.5.21+6 0.5.21+13
Transitive dependencies
charcode 1.1.2
collection 1.14.11 1.14.12
http_parser 3.1.3
meta 1.1.7 1.1.8
path 1.6.4
sky_engine 0.0.99
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test